Announcement

Collapse
No announcement yet.

Swarm on renderfarm

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Swarm on renderfarm

    Hi,

    We are moving slowly towards Unreal for some projects.
    We have a renderfarm counting more than 50 nodes

    I have a couple of question regarding installing swarm on all the nodes to distribute the render process :

    1) Is there a way to have a offline installation of unreal? Downloading 50 times 5Gb doesn't sound like the most optimized scenario, but if not, we'll live with it.
    2) Do we need to install the complete unreal dev kit on the node to be able to render out through swarm?
    3) Our farm consist mainly of xeons that don't meet the minimum requirements. As we only intend to render out through swarm, is there a way to by pass this issue?
    Click image for larger version

Name:	SNAG-0586.jpg
Views:	1
Size:	16.1 KB
ID:	1169088

    Thanks
    Stan

    #2
    You just need your slaves pc to have the DOTnet folder containing the swarm files (swarm agent .exe and coordinator.exe). Don't need the whole engine ;-)

    you can find the folder in C:\Program Files\Epic Games\4.9\Engine\Binaries. Put the folder on your slaves and open the coordinator and enter your settings!

    Technically swarm slaves don't need a gpu since the calculations are made on the cpu and ram. Not sure about your question #3.
    Last edited by heartlessphil; 12-23-2015, 10:18 PM.

    Comment


      #3
      Great info here, thanks a lot.

      Is there any limitation on how many nodes can connect to the coordinator?
      Seems no matter what I do, I only get 9 nodes to connect to the coordinator

      How do I send a job to the swarm coordinator?
      Is there some specific setting I need to check in Unreal to compute on the farm and not locally?

      Thanks again
      Stan

      Comment


        #4
        I'm not an expert but I've followed this very well made guide and it worked. If everything is well configured you don't have to send the job ''manually''... When you start building the lighting it will automatically use all the nodes that the swarm agent can see on the network.

        https://iamsparky.wordpress.com/2010...iple-machines/

        The only thing that you can change in the guide is DOTnet folder replace the whole UDK engine (unreal engine 3). Don't worry about it.

        Comment


          #5
          Hi guys,
          1) I've followed the instructions but my agents don't pick up the job on the farm :



          2) I've got 40 computers with swarm started, but only 6 of them connects to the coordinator.

          Any ideas?
          Cheers
          Stan

          Comment


            #6
            Bump
            Can anyone help me with this please?
            I can't use swarm and it really makes it a pain when we have a renderfarm available!

            Thanks!
            Stan

            Comment


              #7
              Still no one to tell me what I'm going wrong and why this isn't working?
              Please?

              Thanks
              Stan

              Comment


                #8
                Originally posted by Stan Brusse View Post
                Still no one to tell me what I'm going wrong and why this isn't working?
                Please?

                Thanks
                Stan
                I had this problem. DotNet framework is the culprit here. Open the swarm agents and see whether Agents are able to ping to the coordinator. Do the reverse also(i.e ping from coordinator to the clients).

                Download and Install latest dotNet framework from microsoft website hopefully it may solve your problem.

                Comment


                  #9
                  Please post your "Setting"tab main and server.

                  This is my plan.

                  1:Build from only main PC.

                  2:Cancel build.

                  3:Open SwarmAgent from task bar.Open SwarmCoordinator at main PC.

                  4:Open server's SwarmAgent.and ping coordinator from "Network tab".and you can see "[Network] Coordinator ping complete" in "Log"tab.

                  5:Check it out "Available(server) Unassigned" in coordinator.

                  6:Go build,good lack!

                  You can better start 2PC.

                  Sorry bad english.

                  Comment


                    #10
                    Thanks for the response guys.
                    Reinstalling the .NET fixed the missing nodes to connect with the Coordinator.

                    Unfortunately, I still can't render with the farm. The task is still not send to the available agents.

                    quick video explanation :
                    https://youtu.be/aE4mDP-ZJwU

                    Any other ideas?
                    Thanks
                    Stan

                    Comment


                      #11
                      3:Power on server.Do not open server' s SwarmAgent.not open it still now!

                      4:This is 1st time open the app SwarmAgent.

                      Please post your "Setting"tab main and server.Can't read mov, too small.

                      Comment


                        #12
                        Show your settings tab, on main pc and at least 1 other.

                        PS: I Used this great tutorial for setting up swarm on 2 computers. It shows how to set up on more. I personally could only get 2 computers working at a time, but that's likely because of my lack of understanding of DNS and IPconfig. Something i would like to ask you about after you've sorted your own problem

                        The tutorial is for UDK but is the exact same process for unreal https://www.youtube.com/watch?v=WY2z8p6-kg8
                        Last edited by Mentholblue; 01-12-2016, 06:03 PM.

                        Comment


                          #13
                          Originally posted by Mentholblue View Post
                          Show your settings tab, on main pc and at least 1 other.

                          PS: I Used this great tutorial for setting up swarm on 2 computers. It shows how to set up on more. I personally could only get 2 computers working at a time, but that's likely because of my lack of understanding of DNS and IPconfig. Something i would like to ask you about after you've sorted your own problem

                          The tutorial is for UDK but is the exact same process for unreal https://www.youtube.com/watch?v=WY2z8p6-kg8
                          Follow the above tutorial. Make sure the "Settings" corresponds to your network. Enter "*" for "AllowedRemoteAgentName" or enter Name of all Agents manually. Make sure AgentGroup is same for all.

                          One more problem could be DNS name resolution. In my network I always face this problem. I need to enter IP of the coordinator system otherwise, clients fail to get Job from coordinator.

                          Comment


                            #14
                            Hey guys,
                            Thanks I finally maneged to get it working on the farm.
                            Needed to change the defaults settings. Why wouldn't it work with the default settings anyways?

                            Another question :
                            Once I send a build, I have few nodes that works, but the other just try to build the scene for ever :



                            Any ideas?

                            Thanks
                            Stan

                            Comment

                            Working...
                            X