Announcement

Collapse
No announcement yet.

Emissive material not working, no glow?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Emissive material not working, no glow?

    Hey,

    I've been looking at creating some lights for my level. I looked at a few tutorials on how to do it, they are all the same and I have my setup exactly like it. I mean it's only plugging in a multiply in the emissive slot and putting it to a number higher than 1. Yes, whenever I do it, it doesn't work. I posted a screencap below, not sure why it's not working, is there a global rendering option that can break this, or a project setting? Or is this something else I'm missing? Thanks!

    -wes

    Click image for larger version

Name:	emissive.jpg
Views:	1
Size:	295.2 KB
ID:	1168148

    #2
    Glow is a post process effect, there should be Bloom as a default post process but you can control the settings for that by creating a post process volume in your scene and setting it to Unbound (so that it covers the whole scene without having to scale it that size) and then you can change the post process settings by selecting the post process volume and going to the properties.

    Comment


      #3
      Hi,
      Wow thanks for the swift response! I actually jus tcam eback to reply saying I had "Bloom" turned off... oops! lol
      So yea, that was it, thanks a lot!

      -wes

      Comment


        #4
        yes, and it is not a light after all

        Comment


          #5
          Originally posted by Xeny View Post
          yes, and it is not a light after all
          You can turn on contribution to Lightmap on emissive materials. So yeah, they could be lights :P
          SuperGrid: Marketplace Page | Feedback Thread | Demo | Website
          Level design and prototyping for newbies

          Comment


            #6
            Originally posted by zeOrb View Post
            You can turn on contribution to Lightmap on emissive materials. So yeah, they could be lights :P
            Where is this setting? Was not able to find it?

            Thanks

            Comment


              #7
              In case somebody stumbles across this in the future, like I did, the other required setting is Mobile HDR (also in the Rendering section).

              Sorry I can't help with the lightmap question, Wes.

              Comment


                #8
                For future reference Mobile HDR is required if you are making a mobile game which is in the project settings under the rendering tab, if you don’t have this enabled anything of your post process volume won’t work

                Comment


                  #9
                  Originally posted by WesleyTack View Post

                  Where is this setting? Was not able to find it?

                  Thanks
                  Click image for larger version

Name:	EM_Turn_Off_Use_As_SL.jpg
Views:	489
Size:	37.4 KB
ID:	1765943

                  Comment

                  Working...
                  X