Announcement

Collapse
No announcement yet.

Paper2D: Some problems with my Sprites

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Paper2D: Some problems with my Sprites

    Hey guys!

    As i'm still a noob in game development, i wanted to stick with 2D games first. Now i activated the Paper2D plugin and started making animations from my spritesheets.

    But i have a huge problem: my sprites (pixel art) are blurry and they are lit in the scene, eventhough there aren't any lights and i attached a spritematerial to those sprites, where 'Lightning Model' is 'Unlit'.

    Here's a picture of the scene with some sprites:
    Click image for larger version

Name:	ue4_spriteproblem.jpg
Views:	1
Size:	64.9 KB
ID:	1134966

    And here's a picture of the spritesheet, imported in UE4:
    Click image for larger version

Name:	ue4_spriteproblem2.jpg
Views:	1
Size:	133.4 KB
ID:	1134967
    (well, this doesn't really look good :P)

    So... does anyone know the trick? Because i'm simply stumped for an answer.

    Oh, and i didn't changed anything on those settings. So everything's at "normal state".

    Sincerely Leroy
    Last edited by Gamixie; 09-18-2016, 10:00 PM.

    #2
    Hi Gamixie,

    Not sure about the lighting; that should be 100% controlled by the material assigned to the sprite, but you want to change filtering from linear to nearest on the texture you used for your spritesheet to get rid of the blurriness.

    Cheers,
    Michael Noland

    Comment


      #3
      Hey Michael!

      Thanks for your answer!

      I use the 'DefaultSpriteMaterial'. Do i have to change something on this material?

      My character is now 100% sharp, but it seems like he's to sharp, because the right eye is a bit to big. Here's a picture:
      Click image for larger version

Name:	ue4_sprite.JPG
Views:	1
Size:	11.0 KB
ID:	1050887

      What i changed on the spritesheet:
      Filter: Nearest
      Compression Settings: TC Editor Icon

      Sincerely Leroy

      Comment


        #4
        Hi Gamixie,

        You are not at a pixel multiple of the size of your sprite. To get 'pixel-perfect' sprites you need to move your camera in or out (perspective) or adjust the ortho width (orthographic) until you end up at a nice multiple. For example, say you want to have a 320 'pixel' screen but the actual screen width is 1920, then you need to be back so that each 'pixel' is really 6 pixels on the screen. If you're not exactly on a multiple, you'll see some source pixels being larger than others (e.g., if you're at 4.5, then some pixels will map to 4 destination pixels while others map to 5).

        Cheers,
        Michael Noland

        Comment


          #5
          Thanks again.

          Yes, i remember that. Now it's sharp!

          That's wierd: this solved this light issue. The sprites are still lit, but not as much as before.

          I have only one question left: the spritesheet is now sharp, but i have still these wierd red artifacts in the background and now that camera is "pixel-perfect", i see those artifacts in the game. Is there any trick?

          Sincerely Leroy

          Comment


            #6
            This helped me as well. My issue now is that for some reason my sprites are rendering too bright. Turned Mobile HDR off, set texture filter to Nearest, and set compression to TC Editor Icon.

            Even in the editor in "unlit" mode the sprite colors render with their colors brightened.

            Look see:Click image for larger version

Name:	example.png
Views:	1
Size:	46.2 KB
ID:	1050994

            Comment


              #7
              I hope you would capitalize the efforts on other images and projects also,that would be a testing curve and you can also try for 3D rendering for more refined look.

              Comment


                #8
                I went into Tappy Chicken to see how their materials are set up differently than mine. Turns out they are not, so I compared the source art to the displayed Chicken, and the same "lightening" is happening here, too. It's a bug, me thinks.

                Comment


                  #9
                  Hi Sadonis,

                  Check to see if you have automatic exposure/eye adaptation enabled or disabled on your global post process volume. If you disable it (or force exposure to +0), you shouldn't see any change in brightness.

                  Cheers,
                  Michael Noland

                  Comment


                    #10
                    I figured it out, There is a "sRGB" setting that said "uncheck if using alpha channels individually as masks" I thought applied to me. Re-checking it made the texture match again.
                    I went back to tappy chicken to double check what I'd found. Sure enough, there is a grey border to the chicken's (eyes?) that gets lost (bleached white) when you press play. My sprite is matching much better now, but I wonder why Tappy Chicken is still brightening by the smallest ammount...

                    Comment


                      #11
                      The "lighting" is just the bloom post process effect. It makes all white spots light up like that.

                      Comment


                        #12
                        Originally posted by Michael Noland View Post
                        You are not at a pixel multiple of the size of your sprite. To get 'pixel-perfect' sprites you need to move your camera in or out (perspective) or adjust the ortho width (orthographic) until you end up at a nice multiple. For example, say you want to have a 320 'pixel' screen but the actual screen width is 1920, then you need to be back so that each 'pixel' is really 6 pixels on the screen. If you're not exactly on a multiple, you'll see some source pixels being larger than others (e.g., if you're at 4.5, then some pixels will map to 4 destination pixels while others map to 5).
                        I'm having trouble attaining the visual clarity I want. When you say "move back", what do you mean, exactly? By how many Unreal units should we move the ortho width 'back' to get the desirable pixel perfection?

                        My sprites won't show up in nice, crisp form. Running a 1920x1080 monitor.

                        Comment


                          #13
                          Check the texture group and compression settings.For my project i chose 2D pixels for texture group and vectorDisplacementmap(RGBA8) for compression settings.

                          Comment

                          Working...
                          X