Announcement

Collapse
No announcement yet.

Rounded Corner with my shadows

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Rounded Corner with my shadows

    Hello !

    I started a new project and I got this problem with my shadows :

    http://imageshack.com/a/img910/4778/NOc7H9.jpg

    http://imagizer.imageshack.us/a/img910/4299/7WVWyN.jpg

    As you can see, the shadows on the ground have rounded corners, my lightmap seems to be ok but maybe I'm doing it wrong (you can see it by following the link bellow)
    Lightmap : http://imagizer.imageshack.us/a/img908/6490/d8WmVz.jpg

    I set it to 1024 and the building quality is set to production mode.

    Hope we'll find the solution off my problem

    Thanks to everyone !

    #2
    Your lightmap resolution is too low--the setting you changed was for the automatic lightmap UV's generation settings, not the actual lightmap resolution.

    Also, with your lightmap UV's, you could do them better, there are very thin parts there that will cause problems because they are likely to be thinner than a pixel, for better results you would want to reduce the number of seams in your UV's and you should avoid having such small objects split off like that.

    Comment


      #3
      Actually I also set the genreral lightmap at 1024, I tried to replace the staticmesh with just a plan and it works better so you're right, the problem came from the UV's.

      I will try to do it again and I come back to you.

      Thanks a lot

      Comment


        #4
        Try area light shadows. These look lot more natural.

        Comment


          #5
          Hi Jenny,

          What do you mean by saying area light shadows ? Is it a parameter to enable or maybe some special lights to put front of each window (noob inside me) ?

          Thank you very much.

          Comment


            #6
            Stationary lights can either use distance field shadow maps that yield hard shadows or area light shadow which yield physically based soft shadows but will need bit more light map density.

            Comment


              #7
              Ok I found it in the directional light parameter, I'll try to rebuild my scene !

              Thanks

              Comment


                #8
                Ok now it looks more natural as you said

                Click image for larger version

Name:	thks.JPG
Views:	1
Size:	96.9 KB
ID:	1093093

                I will work again on my UV's for better results !

                Thank you all !

                Comment

                Working...
                X