Announcement

Collapse
No announcement yet.

Light Propagation Volume now works with Emissive Material!!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Slavq it did work for me. Just disabled "DBuffer decals". Unreal took good 10minutes to start (on SSD and i7) but after that it worked. (unreal 4.22.2)

    Leave a comment:


  • replied
    Originally posted by Seehr View Post

    Hello Slavq. I guess you need to disable DBuffer decals in the project settings for it to work.
    Hello, thanks, but it didn't change anything in my case, it still looks the same after disabling DBuffer Decals.
    ... Maybe 4.22 will fix some stuff in this area.

    Leave a comment:


  • replied
    Originally posted by Slavq View Post
    Hey, has anyone managed to get it working in 4.21? I doesn't work for me, here is how it looks like: https://imgur.com/a/IuJTwgf
    Hello Slavq. I guess you need to disable DBuffer decals in the project settings for it to work.

    Leave a comment:


  • replied
    Hey, has anyone managed to get it working in 4.21? I doesn't work for me, here is how it looks like: https://imgur.com/a/IuJTwgf

    Leave a comment:


  • replied
    Originally posted by TheSubZer0 View Post
    Its possible to make this volume overlap a static mesh?
    https://answers.unrealengine.com/que...1595/view.html
    There is no such thing as a "Volume" for LPV. LPV is a post process around the area of the camera for dynamic indirect lighting.

    Leave a comment:


  • replied
    Its possible to make this volume overlap a static mesh?
    https://answers.unrealengine.com/que...1595/view.html

    Leave a comment:


  • replied
    Hi Toku - emissive materials and occlusion can be re-enabled by disabling DBuffer decals.

    https://answers.unrealengine.com/que...usion-bug.html

    Leave a comment:


  • replied
    Works then, 4 years later it's broke. Tests in 4.18 indicate that LPV does not take light from Emissive materials anymore, or point lights, and any light injected is not occluded by geometry. Because it is an experimental feature I guess they dont really take it into consideration when updating the engine so a lot of new features have broken it. Anyway, Its about time they implemented a realtime GI solution : /

    Leave a comment:


  • replied
    Hi AkangGG,

    You will need to make sure that your Material has this enabled in the attributes for use with Dynamic Emissive. You will also need to make sure that you have a Directional Light in your scene with Dynamic Indirect Lighting enabled.

    Also, make sure that you've enabled r.LightPropagationVolume=1 in the the ConsoleVariables.ini file in your engine installation folder.

    You will also want to add a Post Process Volume that is unbound so you can adjust the LPV properties for a better look. You can test to make sure that you've enabled LPV by using the Show > Visualize > Light Propagation Volume flag.

    Leave a comment:


  • replied
    sample download please i use ue4.10 and this not work for me

    Leave a comment:


  • replied
    Originally posted by jestersheepy View Post
    Is this with 4.1 or 4.2 snapshot?
    4.1.1 version compiled from source.

    Leave a comment:


  • replied
    Is this with 4.1 or 4.2 snapshot?

    Leave a comment:


  • replied
    LPV is working with baked lighting just fine.
    Just bear in mind I tested only with baked SkyLight.

    Leave a comment:


  • replied
    Originally posted by bigzer View Post
    Is it possible to have the emitting light from emissive materials working on top of baked environment?.
    I dont think its possible right now.

    Leave a comment:


  • replied
    Is it possible to have the emitting light from emissive materials working on top of baked environment?.

    Leave a comment:

Working...
X