Announcement

Collapse
No announcement yet.

Shadows disappear with increased camera distance

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Hi,

    I facing the same problem here. Im new to UE4, can someone please guide me on where to change the value that you are are talking about ?

    Thanks

    Comment


      #17
      @ansonkit

      You want to change these settings in DefaultEngine.ini, it should be located at:
      your_project_folder/Config

      You will want to add the shadow settings under the section:
      [/Script/Engine.RendererSettings]

      I hope that helps (or if you already figured it out that this helps someone else.)

      Comment


        #18
        Originally posted by cgd82 View Post
        @ansonkit

        You want to change these settings in DefaultEngine.ini, it should be located at:
        your_project_folder/Config

        You will want to add the shadow settings under the section:
        [/Script/Engine.RendererSettings]

        I hope that helps (or if you already figured it out that this helps someone else.)
        hate to resurrect this but i am struggling with the same issue.
        tried changing defaultengine.ini in project config and the consolevariables.ini in UE4.10 folder but nothing seems to change.

        i added:
        [/Script/Engine.RendererSettings]
        r.Shadow.FadeResolution=16
        r.Shadow.MinResolution=16
        r.Shadow.TexelsPerPixel=3
        r.Shadow.RadiusThreshold=0.01

        no dice, any tips?

        Comment


          #19
          Far Shadows!

          Dear Everyone,

          Far Shadows are now in the engine and resolve all these issues!

          https://forums.unrealengine.com/show...l=1#post529311

          Rama

          Click image for larger version

Name:	FarShadowsInUe4.jpg
Views:	3
Size:	309.5 KB
ID:	1106349
          100+ UE4 C++ Tutorials on the UE4 Code Wiki, including UE4 Multi-Threading!

          UE4 Marketplace: Melee Weapon Plugin & Compressed Binary Save System Plugin | Rama's C++ AI Jumping Videos | Vertex Snap Editor Plugin

          Visit www.ue4code.com to see lots of videos about my C++ Creations! ♥ Rama

          Comment


            #20
            Is there a solution if you're using spotlights instead of directional lights? My shadows seem to disappear when the camera is about 6-8k units away from the spotlight.

            EDIT: So my problem was that the bounds on the meshes that had clipping/disappearing shadows had to be increased. Select Mesh->Rendering->Bounds Scale.
            Last edited by rantrod; 05-18-2016, 10:27 PM.

            Comment


              #21
              Just playing with the shadow Bias setting a good value is: 0.05 This value can be found in the light properties

              Comment


                #22
                Where I change this values???????




                r.Shadow.FadeResolution - controls how big the light has to be on the screen before it *starts* to fade out.
                - Default Value: 64
                - Can lower this value to keep shadows from fading out at further distances

                r.Shadow.MinResolution - controls how big the light has to be on the screen before it *finishes* fading out, at which point it no longer has cost.
                - Default Value: 32
                - Lower values seem to increase shadow visibility.

                r.Shadow.TexelsPerPixel - Causes a higher resolution to be assigned and then it should fade out less aggressively
                - Default Value: 1.27324
                - Can increase this value to improve shadow rendering visibility & quality

                r.Shadow.RadiusThreshold
                - Default Value: 0.03
                - A lower value of 0.02 or 0.01 greatly increases shadow visibility at far camera distances (seems to have the most impact of all the console commands).

                Comment


                  #23
                  Originally posted by TheSubZer0 View Post
                  Where I change this values???????
                  In console.
                  ' ~ ' key.
                  Twitter | MinimalUI UE4 Editor Theme
                  Dark Themes for: Forum | AnswerHub | Everything else

                  Comment

                  Working...
                  X