Announcement

Collapse
No announcement yet.

hide outline post process effect behind objects

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    hide outline post process effect behind objects

    Hi, please excuse the noob question. I am new to the engine (realtime 3D alltogether)

    I created an outline effect following the instructions in this tutorial

    https://www.youtube.com/watch?v=IEHxjw6VEMQ

    It worked fine, I am prefectly happy with the outline. Only thing is, that it is displayed through objects that are in front of the object with the outline

    Click image for larger version

Name:	outline_issue.JPG
Views:	1
Size:	39.4 KB
ID:	1164729

    If I activate the option "Render CustomDepth Pass" for the cube the outlines of the blue object are blocked, but the cube gets its own outlines. That is something I don't want.
    I basically want some objects rendered with an outline (similar to some cell shading games) and other objects without outlines.

    Is there something I am missing?

    Here is the material I am using:
    Click image for larger version

Name:	highlightMat.jpg
Views:	1
Size:	328.5 KB
ID:	1164730


    Thanks in advance

    #2
    I thought this would be a rather simple question with an easy solution. Maybe that I did something wrong, forget a check-box or miss a connection.
    I guess it is not then.
    Is there another way to achieve the desired result?

    Comment

    Working...
    X