Announcement

Collapse
No announcement yet.

light seeping and blotchy lighting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    light seeping and blotchy lighting

    hey guys, I have a problem with some surfaces

    light map res is at 2048, and built at medium setting. higher doesn't make much difference.

    any help would be much appreciated
    Attached Files

    #2
    Make sure that your walls/ceiling does not extend beyond each other, and it can also help if you have geometry on the other side to block outside light. For the outside surfaces, make sure your walls actually have thickness, so there's some space between one side of the wall and the other.

    Also, make sure that your lightmap UV mapping is as good as possible. For best results, your UV's need to have as few seams as possible, so for instance on your wall you would want the paneling to be modeled into the wall instead of being a mesh that isn't attached and then you could map it to where it's a single piece in the UV mapping which would mean that the only seams would be around the edges.

    Comment


      #3
      thanks for the reply

      I still cant find find a solution.
      I do have a separate block enclosing the whole scene. (1 feet thick)
      I have included a few more screen shots with settings.
      non of the Geo intersects,

      any further help would be much appreciated



      Click image for larger version

Name:	2.JPG
Views:	1
Size:	79.3 KB
ID:	1091162
      Click image for larger version

Name:	3.JPG
Views:	1
Size:	62.0 KB
ID:	1091163
      Click image for larger version

Name:	4.JPG
Views:	1
Size:	191.8 KB
ID:	1091164
      Click image for larger version

Name:	5.JPG
Views:	1
Size:	204.5 KB
ID:	1091165
      Click image for larger version

Name:	5.JPG
Views:	1
Size:	204.5 KB
ID:	1091165
      Click image for larger version

Name:	Capture.JPG
Views:	1
Size:	178.8 KB
ID:	1091166

      Comment


        #4
        I am not an expert when it comes to lightning but I can tell that, in your UVs, those lines are actually too small. You should try using those empty spaces to give more width to them.
        Fighting Game Template: PROJECT: Unreal Fighter 2D

        Comment


          #5
          Disable normal maps contribution to lighmass from project settings. Disable compression from lightmaps.

          Comment


            #6
            You could always try a resolution of 2048 since you have alot of geometry on that same lightmap!

            Comment


              #7
              Your lightmap UV's are bad, don't use automatic flatten UV's because it will not give a good result. Like I was saying, you can map it perfectly for a wall. And make sure your floor/ceiling exactly matches up with your walls and doesn't extend beyond them. Also, set your static lighting level scale for Lightmass back to 1.0, it's best not to change that.

              Comment


                #8
                how would you suggest I lay them out?

                thanks for the reply guys. much appreciated

                Comment


                  #9
                  I would do a planar mapping of the wall and then do a relax by face angle and it should flatten pretty much perfectly, then just make sure that it doesn't go beyond the 1x1 space

                  Comment


                    #10
                    hey.

                    how do I Disable normal maps contribution to lighmass and compression from lightmaps?

                    I am still a bit beta when It comes to UE4

                    Comment


                      #11
                      Originally posted by sgtcuddle View Post
                      hey.

                      how do I Disable normal maps contribution to lighmass and compression from lightmaps?

                      I am still a bit beta when It comes to UE4
                      In project setting under Rendering section.

                      Comment


                        #12
                        sorry I cant seem to find it. unless I am being dim. all I found was compress lightmaps in the world settings tab

                        I and using 4.7.0

                        Click image for larger version

Name:	Capture.JPG
Views:	1
Size:	119.7 KB
ID:	1091351

                        Comment


                          #13
                          You already have it disabled. It's called "Use Normal Maps for Static Lighting"

                          Comment


                            #14
                            awesome.. I am still getting the blotchy on the skirting and nothing I do seams to be working. laying out the uv's diffrently etc

                            Comment


                              #15
                              Can we see your new UV's?

                              Comment

                              Working...
                              X