Announcement

Collapse
No announcement yet.

My Terrain Shaders won´t Load

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    My Terrain Shaders won´t Load

    So i have been working for a time in this project and on this terrain and sudenly when i painted it a bigg part of the teraid stoped to load the textures/shaders and i have tryed to reload them but still the gray boxes.

    What to do to fix this problem?
    Attached Files

    #2
    Make sure that you dont use more than 16 textures in your material -> https://answers.unrealengine.com/que...e-shaders.html
    or https://forums.unrealengine.com/show...While-Painting

    Comment


      #3
      i do not have more then 16 this is how it looks
      Attached Files

      Comment


        #4
        Are your samplers set to shared wrap? It is possible you are still going over the limit due to other samplers (for instance lightmaps), but it may not show the error in the preview window since the layer weights will not show up on the preview mesh, and the landscape material compiles out unused layers. So it is likely showing you only a single compiled layer of the material in that preview. Often you can have too many layers and the problem only shows up once you actually paint all the layers onto the same section of terrain. If you complete erase a layer from a section, the layer is compiled out.
        Ryan Brucks
        Principal Technical Artist, Epic Games

        Comment


          #5
          So i found out as u said that the samplers was not put on shared wrap! Thank you so much for the help!

          Comment

          Working...
          X