Announcement

Collapse
No announcement yet.

SpeedTree materials get completely desaturated when shaded

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    SpeedTree materials get completely desaturated when shaded

    Hello
    As the title says, my imported Speed Trees (default Broadleaf Desktop mesh) with default imported materials all from the .srt file, gets completely desaturated when there is no direct light on it. There seems to be some kind of problem with brightness as well, as the shaded leaves look almost white. Note the contrast between the shaded parts and the ones exposed to the directional light,

    As i said before, no materials were edited, just default properties. The scene is lit by a Skylight and a directional light.Click image for larger version

Name:	UE Forum.jpg
Views:	1
Size:	376.2 KB
ID:	1161751

    Anyone have an idea?

    #2
    Ive had plenty of small problems with Speedtree as well. First, make sure that if you have many different trees made in Speedtree, save them in different folders and import them into different folders in UE4 as well. You can later optimize the textures in UE4 but this helps some clashes that Speedtree import could do. Also when reimporting a failed tree, delete the whole tree from the content, reimporting while textures still in has been buggy for me too. But those might not be your problems.

    One more thing is to set Speedtree leaf materials to "two sided foliage", and connect the base color texture via a "multiply" and "scalar parameter" nodes to the "subsurface colour" in material editor. Otherwise there are pitch black leaves in your tree like you have. But. That doesnt repair the desaturation problem... I would think that is about lightning setting or blocking volumes or something, not Speedtree models themselves? You could try to delete and reimport them. Also try if this happens in some other project, like UE4 starter project with nothing adjusted in it.

    Comment


      #3
      -what happens when you place your tree into the default starter map + build the light?
      -you can add more saturation in your material -> just use the saturation node
      -which engine version do you use?
      -what happens when you change all lights to "Moveable"?

      Comment


        #4
        When i place the tree into the default map and build the lights, exactly the same. But when i change all lights to movable, it gives me the correct result! So then it is an issue with lightmaps? They look alright for the tree, so i still dont get it..

        Engine version is 4.8.3

        Comment


          #5
          Hello,

          SpeedTrees use the exact same material system as everything else, so I am unsure why you are seeing weirdness like this. I do have a few ideas...

          When you imported the tree, did you perhaps enable specular maps? The SpeedTree Modeler's specular currently works differently than UE4's so you probably don't want to use our specular maps unmodified (hence why specular is disabled by default). Your shot kinda looks like your specular is out of control in a scene with really bright lighting, which is why I mentioned it.

          Also, if you're using two-sided foliage shader, be sure to hook up a dark color to the subsurface color. By default that value is white, which will blow out the shaded parts.

          Comment


            #6
            I see those weird stuff on the shaded parts of the ground as well. I don't think it's a problem with SpeedTree specifically.
            Artstation
            Join the support channel
            Gumroad Store

            Comment


              #7
              You were right Greg, i imported again without specular and it solved my problem! Thanks guys!

              Comment

              Working...
              X