Announcement

Collapse
No announcement yet.

Steam particles render issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Steam particles render issue

    So I am facing a new problem.

    The particle's material is translucent. They render fine in all cases except for when I have a mirror behind ( which is exactly where I need them to be). The mirror material is a scene capture cube target into base color (no emissive there).

    Here is a ss showing how they render normally:
    Click image for larger version

Name:	e96bca098b.jpg
Views:	1
Size:	345.8 KB
ID:	1161409

    And here is how they render with the mirror behind (they are almost invisible):
    Click image for larger version

Name:	b3e38ae41c.jpg
Views:	1
Size:	351.6 KB
ID:	1161411


    Any solution?
    Portfolio

    #2
    Have you applied Depth Fade to the material? It looks like the fade distance is too large. It's based on scene depth, so if the 'back' of the particles are too close to the mirror it'll cause them to fade out - which is what happens when they turn to face the camera and you move away. The wall to the right is further from the particles than the mirror, hence they don't fade out.

    SSR Should pick up Particles but I don't think Reflection Cubes do... could be wrong... you're not using forward-rendered translucency are you?

    Comment


      #3
      Hey TheJamsh, thanks for helping.

      I've changed the values of the scene depth and it worked!

      I have another issue with the particles now: whenever I click to move the camera around this emitter stops "flowing"

      Click image for larger version

Name:	82c8210b91.png
Views:	1
Size:	393.5 KB
ID:	1087739

      If I release the mouse then it starts "flowing" again. What's causing this?
      Portfolio

      Comment


        #4
        Cool glad it worked That's just the camera moving through the viewport in Editor mode, when you're in-game it should work fine!

        In the viewport in the top-left, click on 'View' and make sure 'Realtime' / 'Play' is checked too.

        Comment

        Working...
        X