Announcement

Collapse
No announcement yet.

bad shading on a transparent material

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    bad shading on a transparent material

    Hi guys,

    I have a problem with shadows on a curtain mesh of transparent material. DirectionalLight is set to static as well as mesh. UV map is spread over the first and second channel. I try to increase light map resolution to 512. Nothing has changed.

    Have a look at screenshots.

    Click image for larger version

Name:	curtain2.JPG
Views:	1
Size:	190.1 KB
ID:	1159559

    Here also material details:

    Click image for larger version

Name:	curtain_material.JPG
Views:	1
Size:	182.3 KB
ID:	1159560

    I think the mesh is not too havy. It has 10k polys.

    What I want is a transparent curtain that cast a shadow.

    Does anyone have an idea how to fix those ugly shadows ?

    Best regards,
    kentozdr

    #2
    That's a problem with transparent rendering in any game engine. Proper shading requires sorting the pixels and that leads to a really really poor performance.

    I don't see why you're using transparent material though. Curtains aren't transparent in real life. Or is it supposed to be a really thin decorative curtain that are practically see through?

    Comment


      #3
      Have you tried checking the "shadow 2 sided" option?

      You can also the node "lightmass replace" to use a separate opacity that only lightmass sees.
      Ryan Brucks
      Principal Technical Artist, Epic Games

      Comment


        #4
        I don't see why you're using transparent material though. Curtains aren't transparent in real life. Or is it supposed to be a really thin decorative curtain that are practically see through?
        In real life some curtain material passed little light and it is also little see through (it depends on the material) and I wanted create that effect. But propably I will be forced to give up transparency. Thanks for reply.

        Have you tried checking the "shadow 2 sided" option?

        You can also the node "lightmass replace" to use a separate opacity that only lightmass sees.
        I also tried what you write, unfortunately nothing has changed. Maybe I'm doing something wrong because I am not an advanced user, but for now I have to give up of transparency. I will try again in the future to solve this problem. Thank you for your help.

        Comment


          #5
          Originally posted by kentozdr View Post
          In real life some curtain material passed little light and it is also little see through (it depends on the material) and I wanted create that effect. But propably I will be forced to give up transparency. Thanks for reply.



          I also tried what you write, unfortunately nothing has changed. Maybe I'm doing something wrong because I am not an advanced user, but for now I have to give up of transparency. I will try again in the future to solve this problem. Thank you for your help.
          You should look at Subsurface Scattering for curtains. It allows light-passthrough with Stationary and Movable lights. Hope that helps!

          Comment


            #6
            Originally posted by Dec1234 View Post
            You should look at Subsurface Scattering for curtains. It allows light-passthrough with Stationary and Movable lights. Hope that helps!

            I'd suggest that as well. There is also an example of it in the "realistic rendering" scene with the curtain Epic used for the small appartment.

            Comment

            Working...
            X