Announcement

Collapse
No announcement yet.

Can you get certain assets to ignore the skylight/lighting.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Can you get certain assets to ignore the skylight/lighting.

    I have an asset that needs to be as close to black as we can get it, material wise.
    Problem i'm having is we have a skylight that our levels lighting is heavily dependent on, and it's washing out the texture stopping us from obtaining anything close to a dark texture.
    As it stands it's a decal material and i can't find any information, or even if its possible without source to tell a decal to ignore a certain lightsource.

    The asset in question.
    Click image for larger version

Name:	ERlK6Lm.jpg
Views:	1
Size:	67.7 KB
ID:	1158932

    #2
    Either remove Base Color and plug a black color to Emissive, or use 0 for Specular and 1 for Roughness.
    FREE Lightshow
    FREE VR Drum Kit Project

    FREE Color LUT Collection
    FREE Physics Driven Spacecraft Project
    FREE GTA Style Vehicle Interaction
    Dynamic DoF(Depth of Field)
    Camera Crossfade

    Comment


      #3
      Set shading model to unlit.

      Comment


        #4
        I can't use unlit with decals, unless i'm doing something wrong?
        Also isn't black emissive equal to no emissive?

        Any way, i tried both approaches to no avail. It's defiantly the skylight without it i have no problems obtaining the desired effect, trouble is, we need the skylight.

        After playing with it a bit more, i can get a manageable effect on darker surfaces because the decal is always somewhat transparent even with pure white in the opacity slot, so a bit of the material color from what ever object the decal is on is showing through, is there a way to make the decal not be transparent at all? apart from the masked areas.
        as seen here;
        Click image for larger version

Name:	regrgegregre.JPG
Views:	1
Size:	53.8 KB
ID:	1083373
        Last edited by insideitall; 08-07-2015, 02:13 PM.

        Comment


          #5
          I've managed to figure it out, if i enable the dbuffer options in project settings i can get better results.
          Not exactly sure what this option is doing, but if it works it works.

          Comment


            #6
            Okay i prematurely jumped the gun on the fix, turns out it worked for a second or two.
            I've defiantly narrowed it down the the skylight, if i turn that off boom it's how its meant to appear.
            It's not just any skylight though, i fired up a blank project and threw our decal material in there and then a skylight and no matter how much i cranked it it would still work.
            This is making me think i've turned on some setting or turned one off by accident that's forcing this to happen.

            If someone could try replicate a decal in 4.8 for me and share the results i'd like to see if on our end or the engine.

            Comment


              #7
              I've also experimented with decals and have not been able to get them to be fully opaque. It seems like something that shouldn't be that difficult.

              Comment


                #8
                In your new test level did you rebuild the lighting? It might be that it is only showing the statically baked indirect lighting.

                What blend mode were you using for the decal?

                Dbuffer decals render out their own gbuffer so you can have more flexibility in how they are applied. With the regular deferred decals you are locked into the blend modes exactly as they are written.
                Ryan Brucks
                Principal Technical Artist, Epic Games

                Comment

                Working...
                X