Announcement

Collapse
No announcement yet.

How to fix jagged shadows on terrain?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    How to fix jagged shadows on terrain?

    I've spent hours trying to get these artifacts to go away but it just seems like landscapes cant get a high enough resolution amount of polys around the rounded edges of the terrain slopes to have proper shadows

    Tried so many different things I'm not sure how to fix it,
    I'm using a realtime move-able dynamic light and don't want to bake light for such a big outdoor environment. Have not baked light already either.
    I have changed every shadow setting including bias and every one under the advanced settings of the dynamic light
    Also used different resolutions, section sizes of terrain and lod settings etc..but no matter what nothing seems to help!

    Must I make terrain myself without landscape and import it as a static mesh instead & create a ton of polys around these areas for proper topology?
    Or is there any other way to fix this?
    (only terrain casting shadows onto itself in the following pics)

    http://i.imgur.com/xY0ozfg.jpg
    Click image for larger version

Name:	xY0ozfg.jpg
Views:	1
Size:	146.9 KB
ID:	1148459
    Click image for larger version

Name:	zbl8cNu.jpg
Views:	1
Size:	216.0 KB
ID:	1148461
    http://i.imgur.com/zbl8cNu.jpg
    Last edited by CyberDev; 04-21-2015, 05:11 AM.

    #2
    What bias values did you try? As that is definitely the thing to adjust. For real-time large scale lighting you tend to have to raise this quite a bit and sacrifice some contact shadow detail to remove the artifacts at grazing angles.

    Comment


      #3
      -Smooth the part of the landscape a little bit
      -rebuild the light with production quality
      -increase the lightmap resolution of the landscape

      Comment


        #4
        I tried all types of values for bias settings. Also tried smoothing out that area but to get that smooth sloping angle I want there just seems to be not enough polys without a custom mesh?
        Last edited by CyberDev; 04-22-2015, 01:59 PM.

        Comment


          #5
          No other solutions?

          Comment


            #6
            Well, there are not many other options as this is an inherent problem of shadow mapping. Although properly adjusted bias values should allow you to reduce the issue significantly.

            Your only other real-time option are the distance field based "raytraced" shadows as they don't suffer from this specific issue.

            By the way, if your reason for real time lighting is to save lighting build time I would advice against it. Static lighting might have its own headaches, but in the end I would never sacrifice a significant part of my performance and quality simply to ease development.

            Comment


              #7
              I was kind of going by what viper said in another thread-

              Originally posted by darthviper107 View Post
              For large worlds, I would avoid using lightmaps, at the very least you will end up with a large amount of hard drive space taken up by them and a huge game install.
              If you can wait to test out upcoming 4.8 it has some dynamic GI updates and might suit your purpose better. The Kite demo will also be made available which is a large outdoor world example.
              The 4.8 kite demo does not have any baked light does it? Isnt that the future? My project will be directed towards hardware of the future in like 2 years, where 980ti/titanx power is standard for most people playing intense pc titles along with multi gpu DX12 setups when the next generations of cards come out. So it shouldnt be a problem to not have to wait for baking large worlds in 4.8 and future hardware?
              Last edited by CyberDev; 08-22-2015, 12:18 AM.

              Comment


                #8
                I still cant get rid of this problem especially now that I'm using bigger terrains. I'm using the maximum landscape size and it seems impossible to bake lights on it because its so big. Swarm crashes or the editor crashes or it just takes way to long.

                How can I get rid of these shadow artifacts on a fully dynamic non baked landscape?

                Comment


                  #9
                  You can solve this through adjusting the cascade and bias settings.

                  I have done so for two maps now.

                  i would love to post a screenshot but 4.9.1 just crashed on me......

                  Comment


                    #10
                    Light settings included in screen shots. It took some experimentation.

                    Something like this



                    Becomes something like this

                    Attached Files

                    Comment


                      #11
                      Hi all, I have the same problems with dynamic lighting. I choose to ignore this at the moment, otherwise if i stop in every thing I have problems, i never get nothing done.
                      That said, I am using a dynamic movable light with ray traced shadows. The problem is more noticeable when the light angle is parallel to the landscape.
                      I will post some screens as soon i get back home

                      Comment

                      Working...
                      X