Announcement

Collapse
No announcement yet.

Shadow Help. Large world dynamic shadows. please advise.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Shadow Help. Large world dynamic shadows. please advise.

    Ok so here is the situation. I have a very large world. 100kmx100km= 1000 sq/km it is made from 100 10x10km tiles. As you can imagine the presents significant challenges to lighting as it makes static lighting and baking with lightmass an impossibliity. yes ther are too many areas of overlapping shadows hat making even baking a tile at a time an impossibility. So I was told I should just do with dynamic lighting.

    I think what I have done is correct. I set my directional light that is part of the default sun/sky system from static to stationary. " it doesnt seem to work at all when set to movable"

    I also enabled distance field ray traced shadows. There is what I'm seeing.

    full screen here

    but here is a crop of the area of concern.:
    Click image for larger version

Name:	ShadowIssue_crop.jpg
Views:	1
Size:	50.8 KB
ID:	1147283

    As you can see after a distance the shadows become less triggered by ground contact. This is past what I assume to to be the first cascade. I have turned the overlap all the way up and I have tried to turn up the number of cascades but nothing seems to affect the distance at which it occurs or minimizes it. I have tried changing every parameter in the cascaded shadow map section of the light and cant get any real change.



    so anyone know how I can extend this out further? I have to make an animation traveling down this pipeline and seeing that shadow popping in mid frame is very annoying.
    James Brad Barnette
    Senior Creative Artist
    3Dmotif LLC

    #2
    Check out this: https://docs.unrealengine.com/latest...ing/index.html

    You need to adjust how it controls the cascaded shadows distance compared to where it uses raytraced shadows.

    Comment


      #3
      yeah that page is where I started but nothing other that blending value made any difference in how far out that shadow goes. Is it possible that I'm hitting some hard coded limit.


      I made a video clip so you can see it in motion so you can see what I mean it is like the shadow just pops in mid screen.


      Not sure if it matters but pipelines are made with terrain splines

      James Brad Barnette
      Senior Creative Artist
      3Dmotif LLC

      Comment


        #4
        Holy **** it dos look like it is a terrain spline issue! damnit! I just laid a section of the pipe in as a static mesh right next to it and the shadow is completely different! Does anyone know a way it fix this?
        James Brad Barnette
        Senior Creative Artist
        3Dmotif LLC

        Comment


          #5
          Ray traced distance field shadows can't support spline meshes, this is listed in the doc. I'm guessing the region in which the shadow shows up is standard Cascaded Shadow Maps, controlled by Dynamic Shadow Distance.

          Comment


            #6
            ok are the shadows that we see in the view-port representative of the cascade shadow maps? I turned off the raytraced maps since you said they don't do anything and I have tried the draw distance for the stationary light shadow at everything between 1-100,000 and it make zero difference in how far out the shadow still draws. I have spent 2-3 hours playing with these values and cant see a bit of difference in any of them.
            James Brad Barnette
            Senior Creative Artist
            3Dmotif LLC

            Comment


              #7
              You may have some success by inserting this in your consolevariables.ini file:

              r.Shadow.RadiusThreshold=0.01 (default is 0.03)
              r.Shadow.FadeResolution=8 (default is 64)
              r.Shadow.MinResolution=1 (default is 32).

              These values affect the distance at which objects cast shadows. Just be aware that this might affect performance.
              Last edited by Frepp73; 04-01-2015, 01:18 PM. Reason: changed config.ini to consolevariables.ini
              http://www.pixelpirates.se/
              Architectural and product visualisations

              Comment


                #8
                Originally posted by Frepp73 View Post
                You may have some success by inserting this in your config.ini file:

                r.Shadow.RadiusThreshold=0.01 (default is 0.03)
                r.Shadow.FadeResolution=8 (default is 64)
                r.Shadow.MinResolution=1 (default is 32).

                These values affect the distance at which objects cast shadows. Just be aware that this might affect performance.
                Thank you very much I will give it a shot.


                Thant being said why is this stuff not available in the editor under there project settings? There should be a thing that loads this stiff as a table and allows for the values to be toggled and/or changed.

                Update I assume you mean the DefaulEngine.ini in the project config folder? I couldn't find a plain config.ini
                Last edited by calmasacow; 04-01-2015, 12:41 PM.
                James Brad Barnette
                Senior Creative Artist
                3Dmotif LLC

                Comment


                  #9
                  I think these settings are not available in the editor cause they do cause extra load on the computer, and Epic probably judged that the default settings are usually enough (which they usually are if you're not making very big scenes). You can however use them in game via the console, I think.

                  Concerning the file, it's consolevariables.ini. My bad.
                  http://www.pixelpirates.se/
                  Architectural and product visualisations

                  Comment

                  Working...
                  X