Announcement

Collapse
No announcement yet.

Light build help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Light build help

    hi, this is my first post on this forum,

    I have a problem I built light map objects as seen in the screen shot map lights has black surface. Light maps for each facility built in 2048. Why does this happen? in a blender created maps UV Smart Project.

    Click image for larger version

Name:	ue4_1.jpg
Views:	1
Size:	768.6 KB
ID:	1147181

    #2
    can you double check that those faces have surface area in the UV's and are not over lapping? I think they do but it would be one place I'd check. Then I'd check the normals... can you confirm those are right?
    www.youtube.com/user/destruct007

    Comment


      #3
      normals checked is good, over lapping also checked, I built a second layer of UV light maps in blender using smart uv project, referred to as the building of light these surfaces are black. I also tried to delete the second layer of UV, ue4 generated map shown in the screen shot but still the same problem.

      Click image for larger version

Name:	ue4_2.jpg
Views:	1
Size:	630.3 KB
ID:	1071600

      Comment


        #4
        Could it be that the UV space is too small? Even at 2k, maybe you need to make that face wider in UV space. There are a lot better UV's you can do with those edges. You're not using most of the space.
        www.youtube.com/user/destruct007

        Comment


          #5
          I do not use these space because the object is divided into 6 smaller parts, in another object of these places are closed, so I think of how it will cover all the space will not be the same amount of light maps, Is that true? for the import option appears generate light map UVs can better take advantage of it?

          Comment


            #6
            sorry this is a ue4 light map uvs generate, two layers uv is not made by UVS layer blender, I tried this method but it does not work all the time goes black space

            Comment


              #7
              well for small thin lines you can make the light map UV's wider so they can get light. Its not about how well they are laid out, or what software, its about forcing it to get more pixels of UV space in that UV set.

              All that said it might still not be the issue, is that line black when you look at it untextured? unit? or does it only appear when you bake lights?
              www.youtube.com/user/destruct007

              Comment


                #8
                Try increasing padding.
                flickr | twitter

                Comment


                  #9
                  There needs to be more space between pieces of the UV's
                  Also, try to keep the top of the edge with the sides, they don't need to be separated like that. On the long pieces, you may want to add a loop in the middle so that you can then split at that point so that when you do the UV's you don't have such long skinny objects there and they'll use up more of the space.

                  Comment


                    #10
                    You should really avoid making light map UVs that are 90% unused, it's a waste of memory and generally means there's a better want to approach that model. My first suggestion would be to break off the 90 degree bends into their own UV islands so you just have a bunch of straight lines. I'd also suggest beveling the top exposed edge of the model and merging the UVs so there's less splits. Actually, ideally I'd probably just have the trim modeled in with the actual wall or design the scene to be modular and use smaller pieces of trim.

                    Comment

                    Working...
                    X