Announcement

Collapse
No announcement yet.

Lighting not building

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Lighting not building

    Hi there, I'm sure I'm missing something really simple here but I can't seem to build the lighting at all. I click 'build lighting only' and then when I click play there is an error message saying lighting needs to be rebuilt.

    I have noticed that the Build Status dialogue box appears only for a split second. I'm assuming this is causing the problem as I have enough lighting and assets in my scene to keep the light build busy for more than a split second.

    Thank you for reading

    Selwyn

    #2
    Try disabling static lighting in World Settings by hitting "No Pre-Computed Lighting" then rebuild.

    Edit: Just so you know this will remove static lighting, but /should/ allow you to build

    Also, have you tried building all levels? Do you still get the error?
    Last edited by Lindsay Aries; 03-18-2015, 02:07 AM.

    Comment


      #3
      Hey Selwyn!
      Probably there is some error preventing light from Building. Navigate to Top bar -> Window -> Developer tools -> Message log and see if there is something off. If it is - please post it here so we can help you to solve this issue
      SuperGrid: Marketplace Page | Feedback Thread | Demo | Website
      Level design and prototyping for newbies

      Comment


        #4
        Hey guys thanks for responding. I will try your suggestions when I get home later and will post my results.

        @Lindsay Aries: In regards to removing all static lighting when I go into play mode everything will run very slowly. For taking a screenshot of my scene however this will probably work.

        Comment


          #5
          Hey zeORB, when I build geometry it only tells me I need to rebuild lighting. When I then click Build Lighting Only this message then disappears but when I click play I still have the error message i the top left saying lighting needs to be built 22 unbuilt objects

          Comment


            #6
            Ok so it seems to only be an issue with the latest build (4.7.3). I installed 4.6.1 and the light build worked exactly as it was supposed to

            Comment


              #7
              Update: I installed UE4 (build 4.7.3) onto my work computer and it worked just fine. The first time I ran the lighting build it told me a firewall was blocking swarm and if I wanted to allow it through the firewall. After allowing it through it built the lighting and didn't prompt me again after that.

              Previously, I had temporarily disabled my firewall on my home computer to see if it that would fix the problem but it didn't work. However, I'm pretty sure this is a firewall problem and I probably missed something last time.

              I'll have another look at it tonight and post my results.

              Thanks for reading

              Selwyn

              Comment


                #8
                I have done everything I can regarding the firewall but no success.

                This is what I get in the log for Swarm Agent

                21:06:49: Starting up SwarmAgent ...
                21:06:49: ... registering SwarmAgent with remoting service
                21:06:49: ... registering SwarmAgent network channels
                21:06:49: ... initializing SwarmAgent
                21:06:49: ......... certificate check has failed
                21:06:49: ...... initializing cache
                21:06:49: ......... using cache folder 'C:/Users/selwyn369/AppData/Local/UnrealEngine/4.7/Saved/Swarm\SwarmCache'
                21:06:49: ......... recreating SwarmAgent cache staging area
                21:06:49: ...... initializing connection to SwarmCoordinator
                21:06:49: ......... using SwarmCoordinator on RENDER-01
                21:06:51: ......... SwarmCoordinator failed to be initialized
                21:06:51: ...... initializing local performance monitoring subsystem
                21:06:53: ... initialization successful, SwarmAgent now running
                21:06:58: [Interface:TryOpenConnection] Local connection established
                21:06:58: [Interface:OpenJob] Error: Invalid namespace

                Any ideas what these errors are about?

                Comment


                  #9
                  Selwyn, try to delete SwarmCache in C:\Users\YourUsername\AppData\Local\UnrealEngine\4.1\Saved\Swarm\SwarmCache
                  If it does not help - create post on Answerhub
                  SuperGrid: Marketplace Page | Feedback Thread | Demo | Website
                  Level design and prototyping for newbies

                  Comment


                    #10
                    This didn't work. Everytime I deletedthe folder it would reappear when I attempted to build the lighting.

                    I have now posted on Answerhub

                    Thanks anyway

                    Selwyn

                    Comment

                    Working...
                    X