Announcement

Collapse
No announcement yet.

[Error] "Maps need lighting rebuilt."

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Error] "Maps need lighting rebuilt."

    Hello, just calling in to ask about a minor problem.

    So, I just went and added the inestimable @fighter5347's Foliage Starter Kit to a project -- it's great -- but when I set my directional light to stationary and go to build the lighting, I get this in my message log:

    WorldInfo_0 Maps need lighting rebuilt

    And the lighting looks terrible. I've switched my light to movable and things look much better, but I hear movable lights eat up a lot of performance in larger levels. I'm not keen on that.

    So, is this a common error? I did not get it before using the Foliage Kit, but @fighter5347 assures me there's probably something else going on. Any help is appreciated.
    Still new to this Unreal business, even after two years.

  • #2
    -A solution could be that you move your map + assets into a new project
    -which engine version do you use?

    Comment


    • #3
      Whenever you have an actor that is set to cast static shadows, you will need to rebuild lighting for stationary lights. Do you have a lightmass importance volume? Also, as Fighter asked, which version are you using? It seems there might have been a similar issue with 4.3 - https://answers.unrealengine.com/que...t-ive-don.html

      Comment


      • #4
        Using 4.7.2, and I do have a lightmass importance volume set up. I could try moving everything into a new project, but doesn't that seem like an unsustainable solution?
        Still new to this Unreal business, even after two years.

        Comment


        • #5
          Originally posted by Cinebeast View Post
          Using 4.7.2, and I do have a lightmass importance volume set up. I could try moving everything into a new project, but doesn't that seem like an unsustainable solution?
          I know that it's not the best solution, but I read that it could might solve the problem -> because there are just two thread with the same topic around and all of them solve the problem with using a new project

          Comment


          • #6
            Ack! You know what I did? Simply restarted Unreal. When I switched to stationary and rebuilt the lighting it went fine.

            Oh well. Sorry for making a mountain out of a molehill. Thanks for all the advice.
            Still new to this Unreal business, even after two years.

            Comment


            • #7
              Hi everyone, I started having this problem as I was adding foliage. I thought that if I reduced its lightmap to 8 (instead of 128) would help but it doesnt.
              As it appears, the only solution is to move my map and assets to a different level/project?

              Could someone explain to me how to do that? It took me a looong time to build everything
              What is the relationship between Project-Level-Maps? I thought the later two were the same but apparently they arent?

              Thanks in advanced for the help!

              Comment


              • #8
                Hi again,
                I migrated all the assets to a new project but eventually the error came up again. After messing around with the engine, I found that I had another map using the same assets/textures so i deleted it (just in case) and it seems that it worked... Now im able to build everything again and no error.

                Every time I open the editor I start in this phantom level (which has nothing on it) so i move to my custom level and decide not to save that old one. Is there any way of seeing ALL the levels/maps inside the same project, so that i can delete the unwanted ones?

                Regards,
                Seichi

                Comment


                • #9
                  I had suffered this problem from foliage, InstancedStaticMeshComponents as well.
                  However have found a solution to fix it in 4.7.6.

                  1. Open 'World Settings'.
                  2. Goto 'Lightmass' category.
                  3. Check 'Force No Precomputed Lighting'.
                  4. A popup will appear. Press 'OK'.
                  5. Press 'Build All' or 'Build Lighting Only'. Static Lighting will be crack. That's OK.
                  6. Save the map.
                  7. Reload the map. Open another map and open the map or double click the map in content browser.
                  8. Lightmaps will be 0 in Lightmass categoty. If not, load the map again.
                  9. Uncheck 'Force No Precomputed Lighting'.
                  10. Save the map.
                  11. Press 'Build All' or 'Build Lighting Only'.
                  12. Solved.
                  Last edited by donggas90; 08-13-2015, 03:55 PM.

                  Comment


                  • #10
                    Worked great! thanks much!!!

                    Originally posted by donggas90 View Post
                    I had suffered this problem from foliage, InstancedStaticMeshComponents as well.
                    However have found a solution to fix it in 4.7.6.

                    1. Open 'World Settings'.
                    2. Goto 'Lightmass' category.
                    3. Check 'Force No Precomputed Lighting'.
                    4. A popup will appear. Press 'OK'.
                    5. Press 'Build All' or 'Build Lighting Only'. Static Lighting will be crack. That's OK.
                    6. Save the map.
                    7. Reload the map. Open another map and open the map or double click the map in content browser.
                    8. Lightmaps will be 0 in Lightmass categoty. If not, load the map again.
                    9. Uncheck 'Force No Precomputed Lighting'.
                    10. Save the map.
                    11. Press 'Build All' or 'Build Lighting Only'.
                    12. Solved.
                    Advanced 3d Footprints | Videos | Open Source Mine Sweeper

                    Comment


                    • #11
                      donggas90, you are a saint. This just got me out of a MAJOR bind. Thank you.

                      Comment


                      • #12
                        Originally posted by donggas90 View Post
                        I had suffered this problem from foliage, InstancedStaticMeshComponents as well.
                        However have found a solution to fix it in 4.7.6.

                        1. Open 'World Settings'.
                        2. Goto 'Lightmass' category.
                        3. Check 'Force No Precomputed Lighting'.
                        4. A popup will appear. Press 'OK'.
                        5. Press 'Build All' or 'Build Lighting Only'. Static Lighting will be crack. That's OK.
                        6. Save the map.
                        7. Reload the map. Open another map and open the map or double click the map in content browser.
                        8. Lightmaps will be 0 in Lightmass categoty. If not, load the map again.
                        9. Uncheck 'Force No Precomputed Lighting'.
                        10. Save the map.
                        11. Press 'Build All' or 'Build Lighting Only'.
                        12. Solved.
                        donggas90 !! You are amazing. Thank you !
                        Here is my basic tutorials for SketchUp to Unreal.

                        SketchUp to Unreal Engine Tutorials

                        Comment


                        • #13
                          its stupid perhaps but since i'm new to unity i'm having problems with your point

                          6. Save the map.
                          7. Reload the map. Open another map and open the map or double click the map in content browser.

                          how and where do i save a map. what is a map. i'm almost there... please help

                          Comment


                          • #14
                            This worked!

                            Comment


                            • #15
                              Hi Can you pls explain how to do 6. 7. 8. PLS PLS PLS !!!! IT IS URGENT !!!!

                              Comment

                              Working...
                              X