Announcement

Collapse
No announcement yet.

Ray traced soft shadows , Situation (Problem)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Ray traced soft shadows , Situation (Problem)

    I have a skyscraper(Building) in my game and i want to enable "Ray-traced soft shadows" but i get very ugly resolution problems even with the quality set to 100.0, I get these problems because my
    building mesh is too big! I was recommended two options,

    1) - Divide your building mesh into more modular pieces and enable RTSS(Ray-traced soft shadows) on each part (which would solve my problem) but inflicts another problem (see below)

    2) - Increase the "RTSS" resolution volume manually in the source code.

    Now with solution 1, it would take me 40 X longer if i was to divide my mesh into 40 parts, and that's a problem when i have hundreds of large assets!.
    With solution 2, Unfortunately there is absolutely no documentation. So i'm asking (you) the forums to see if there are any other options or solutions to my situation. Thanks for considering my topic!

    #2
    When you say you have the quality set to 100 are you referring to the "Distance Field Resolution Scale" setting in the static mesh editor? Just want to make sure I know which setting you are looking to increase.

    This all depends on how much higher you would need to go in order to achieve the results you're looking for, if it is going to be quite a bit more it will become (if it's not already) too costly to performance. If this is the only building in your scene it might work, but if this is a game with multiple buildings you are going to run into issues.

    Also when you say it will take you 40x longer do you mean 40x longer to build the lighting? And one last thing, could you post a screenshot showing the issues you are seeing for us? Thanks!
    Free Community Ocean & Sky Project || Join us on Discord! || Trello Roadmap

    Comment


      #3
      Distant fields work better with more mid size and smaller objects. With any mesh using DFs I've never had to approach that high of a resolution. Typically going above 1-5 shouldn't be necessary. DFs work really well with modular pieces.

      When troubleshooting any DF issues its best to use show > visualize > mesh distance fields.
      Tim Hobson | Learning Resources | Epic Games
      UE4 Documentation

      Comment


        #4
        Originally posted by DotCam View Post
        When you say you have the quality set to 100 are you referring to the "Distance Field Resolution Scale" setting in the static mesh editor? Just want to make sure I know which setting you are looking to increase.

        This all depends on how much higher you would need to go in order to achieve the results you're looking for, if it is going to be quite a bit more it will become (if it's not already) too costly to performance. If this is the only building in your scene it might work, but if this is a game with multiple buildings you are going to run into issues.

        Also when you say it will take you 40x longer do you mean 40x longer to build the lighting? And one last thing, could you post a screenshot showing the issues you are seeing for us? Thanks!
        1) - Yes i am referring to the "Distance field resolution scale" setting.

        2) - No i don't just mean 40x longer to build the lighting, I mean i would have to import 40 parts separately and then reconstruct the building in the editor using those 40 parts. As well as building the lighting 40 times.

        3) - I'm trying to upload images but i keep getting "<p> Database Error </p>". I will upload images when i am able.
        Attached Files

        Comment


          #5
          Originally posted by Tim Hobson View Post
          Distant fields work better with more mid size and smaller objects. With any mesh using DFs I've never had to approach that high of a resolution. Typically going above 1-5 shouldn't be necessary. DFs work really well with modular pieces.

          When troubleshooting any DF issues its best to use show > visualize > mesh distance fields.
          Yes I've already debugged my issue and i was told it was because my building wasn't "Modular" enough, (which i was not informed about in the documentation.) Which is why i am asking the forums for work around's.

          Comment


            #6
            https://docs.unrealengine.com/latest...ion/index.html

            This link has more troubleshooting tips and limitations mentioned. Even though this is listed under DFAO the methods for generating the AO and Shadows is based off the diatance mesh. As Distance Fields grow with the engine I'd like to see a general overview page then break down into the different features it offers.
            Tim Hobson | Learning Resources | Epic Games
            UE4 Documentation

            Comment


              #7
              Andrew I'm afraid you're out of luck, there's just no way to represent huge objects with distance fields in volume textures as the memory needed is unreasonable. Internally a single mesh is limited to 128^3 resolution (4mb) and the entire atlas is limited to 512^3 (256mb). The 128 clamp is in MeshUtilities.cpp somewhere (don't have the code in front of me). Even if you raised it, at best you would get a x2 or x4 increase in resolution which is not going to make huge objects work.

              One thing you can do to handle huge objects is to use 'Far' cascades that are coming in 4.8. These are cascaded shadow maps that only include Landscape and other static meshes tagged as bFarShadow. These can be pretty efficient with proper LOD. In the open world GDC demo we used the far cascades for huge rocks and Landscape. RTDF shadows are only for trees + medium rocks.

              Comment


                #8
                Originally posted by DanielW View Post
                Andrew I'm afraid you're out of luck, there's just no way to represent huge objects with distance fields in volume textures as the memory needed is unreasonable. Internally a single mesh is limited to 128^3 resolution (4mb) and the entire atlas is limited to 512^3 (256mb). The 128 clamp is in MeshUtilities.cpp somewhere (don't have the code in front of me). Even if you raised it, at best you would get a x2 or x4 increase in resolution which is not going to make huge objects work.

                One thing you can do to handle huge objects is to use 'Far' cascades that are coming in 4.8. These are cascaded shadow maps that only include Landscape and other static meshes tagged as bFarShadow. These can be pretty efficient with proper LOD. In the open world GDC demo we used the far cascades for huge rocks and Landscape. RTDF shadows are only for trees + medium rocks.
                Ok thanks, Ill wait until 4.8 comes around.

                Comment

                Working...
                X