Announcement

Collapse
No announcement yet.

Weird artifacts

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Weird artifacts

    Im having a weird effect on walls (I hope you can see it, with video compression is not very clear)



    Is like weird shadows on the walls and roof.

    Is this some kind of artifacts? I suspect my Lightmass configuration maybe..

    Thanks!

    #2
    You can try adjusting the Quality settings of lightmass and the smoothing settings, it might increase the lighting build times though. If you haven't already, build using Production quality, and make sure you have a lightmass importance volume setup.

    Comment


      #3
      OK i will try (i tested most of the things mentioned), However, I not sure if in the video is appreciated the "effect" of shadows that move through the wall and roof. Due to the compression of the video is not very clear, but the effect is most noticeable than in the video.
      I can upload another video more detailed if the strange effect is not appreciated.

      Comment


        #4
        It looks like DFAO(Distance Field Ambient Occlusion.) Turn the Skylight in your level into Static or disable DFAO in project settings if you dont want that feature at all.
        FREE Lightshow
        FREE VR Drum Kit Project

        FREE Color LUT Collection
        FREE Physics Driven Spacecraft Project
        FREE GTA Style Vehicle Interaction
        Dynamic DoF(Depth of Field)
        Camera Crossfade

        Comment


          #5
          Nice eye, Jacky. that does look like DFAO. I didn't catch that the first time I watched it earlier today.

          @Alexarg: If you're using DFAO you can adjust these in the skylight settings.

          https://docs.unrealengine.com/latest....html#settings
          Tim Hobson | Learning Resources | Epic Games
          UE4 Documentation

          Comment


            #6
            Originally posted by Jacky View Post
            It looks like DFAO(Distance Field Ambient Occlusion.) Turn the Skylight in your level into Static or disable DFAO in project settings if you dont want that feature at all.
            Originally posted by Tim Hobson View Post
            Nice eye, Jacky. that does look like DFAO. I didn't catch that the first time I watched it earlier today.

            @Alexarg: If you're using DFAO you can adjust these in the skylight settings.

            https://docs.unrealengine.com/latest....html#settings
            Yes!, the Skylight config was the problem, for some reason i had the intensity way too hight. Happy again
            Thanks all for your responses

            Comment

            Working...
            X