Announcement

Collapse
No announcement yet.

Using your own Unwrap for lightmapping

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Using your own Unwrap for lightmapping

    The default setup is "Source Index = 0 | Destination Index = 2"
    I don't understand the point of this at all. It just creates a 3rd UV channel, what a waste.
    How do I make it so it just uses the UV unwrap I already did just fine on Channel 0?
    I tried setting Source Index and Destination Index to 0, but that causes issues.

    #2
    Turn off the lightmap generation, if you already have a lightmap in channel 1 then it'll use it.
    By default in the import options it will generate a new lightmap UV using channel 0

    Comment


      #3
      Originally posted by darthviper107 View Post
      Turn off the lightmap generation, if you already have a lightmap in channel 1 then it'll use it.
      By default in the import options it will generate a new lightmap UV using channel 0
      Click image for larger version

Name:	untickedlightmapbox.png
Views:	1
Size:	11.0 KB
ID:	1068122

      I've tried that as well. Here is what it does.

      Click image for larger version

Name:	invalidlightmap.png
Views:	1
Size:	182.2 KB
ID:	1068119
      Click image for larger version

Name:	overlappinguvs1.png
Views:	1
Size:	28.0 KB
ID:	1068118
      Click image for larger version

Name:	uvissues.png
Views:	1
Size:	222.0 KB
ID:	1068117

      Overlapping? Really? Let's have a look.

      Click image for larger version

Name:	actuauvs.png
Views:	1
Size:	20.3 KB
ID:	1068120

      Doesn't look like its overlapping at all. What settings did I use to pack them in 3d Studio Max?
      Click image for larger version

Name:	3dsmaxpackuvs.png
Views:	1
Size:	7.0 KB
ID:	1068121

      There is no overlapping (that's the point of the 0.02 padding).

      Comment


        #4
        In the mesh editor go to the details panel on the right > Static Mesh settings:

        Click image for larger version

Name:	626px-BSPLMSetup.png
Views:	1
Size:	142.4 KB
ID:	1068123

        if you want channel 0 (your texture UV) to be your lightmap set it as such.

        Next set the lightmap resolution you need.
        Tim Hobson | Learning Resources | Epic Games
        UE4 Documentation

        Comment


          #5
          Thank Tim, you pointed me exactly to where the issue was.

          Here is where the confusion stems from for those suffering similar issues, and so maybe this can be made clearer in the future.
          Click image for larger version

Name:	issuefound.png
Views:	1
Size:	9.3 KB
ID:	1068124

          This checkbox is defaulting to 1, even though in all other cases the default is 0.
          1 is baked tiling UVs, so clearly those DO overlap.

          EDIT: Also, don't use UV channel 0 for lightmaps. I thought you had to because it was showing up as the default on the other box, and I think because UDK used 0 as well.
          But in UE4, if you put your textures on Channel 1, you then have to specify a texture coordinate node for every material that you place on the mesh, pain in the neck, not advised.
          Last edited by DIFTOW; 03-10-2015, 09:47 PM.

          Comment

          Working...
          X