Announcement

Collapse
No announcement yet.

Inaccurate shadows

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Inaccurate shadows

    Hi guys, I hope somebody can help me. I already asked this question inside the AnswerHub, but the suggestion did not help me.

    It seems there is something wrong with my mesh imported from Blender to UE4.

    What I did so far :

    in Blender

    - built a second UV channel in Blender, used an image as background (512x512 pixels)
    - hand unwrapped the whole mesh, left exactly 2-4 pixels space
    - left no free space in the UV editor
    - split all hard corners and avoided overlapping UVs
    - checked all normals, adjusted pivot point

    in UE4

    - selected the proper UV channel (lightmapCoordinateIndex), deactivated 'generate lightmap UV'
    - tried different lightmap resolutions, indirect lighting quality, indirect lightning smoothness, lightning build quality ...

    But I canĀ“t get rid of small inaccuracies, which drives me nuts.

    If somebody could help me I would really appreciate it. Please let me know if you need the .blend file.

    Click image for larger version

Name:	bridge.jpg
Views:	1
Size:	361.9 KB
ID:	1145404

    #2
    Have you increased the lightmap resolution of the shadow casting object or the shadow "accepting" mesh? -> you will have to increase the one from the shadow "accepting".
    Also make sure to add a lightmass importance volume

    Comment


      #3
      Actually casting and accepting mesh are one object. And yes, lightmass importance volume exists and is made big enough to fit the mesh

      Comment


        #4
        Depending on the UV layout that you have for your lightmap can make a big difference in the quality resolutions of the shadows. Looking at the Lightmap resolution and the UV layout for the lightmap would be the two areas I would start with. Depending on the size of the object that can definitely affect the lightmap resolution because UV shells will take up more space in the 0,1 space. Often times it's better to break down larger objects into chunks that can more effectively use the 0,1 space to get better texel density without the need to continually adjust the lightmap resolution to a higher value.

        What is your lightmap resolution set to currently?

        Can you post a screenshot of your lightmap UV?


        Also take a look at this troubleshooting guide as well for more common lighting issues: wiki.unrealengine.com/LightingTroubleshootingGuide
        Tim Hobson | Learning Resources | Epic Games
        UE4 Documentation

        Comment


          #5
          Thank you for your extensive reply.

          My current lightmap resolution is 512, if I increase it to 1024 it gets a bit better but as it is mentioned in the lightning guide being a brute force method, I would like to find another way. Attached please find the UV map, which probably will be the reason for the inaccuracies as you said.

          I am not 100 percent sure if the UV layout is setup properly. 'Snap to pixel' is activated, left a 2 pixel frame around the layout and tried to keep the relative size of each piece.

          In case you need the blend. file, please let me know. My last try would be splitting up the mesh.


          Click image for larger version

Name:	UVmap.png
Views:	1
Size:	371.6 KB
ID:	1067872
          Last edited by Noiling; 03-07-2015, 10:55 AM.

          Comment


            #6
            Should I maybe stick to this guide:

            https://docs.unrealengine.com/latest...ing/index.html

            Instead of single pieces is it maybe better to use seams and only cut the mesh in big parts?

            Comment


              #7
              Hi Noiling,

              For what it's worth, you should check the scale of your mesh in ue4.
              I use to work with max, unit = cm, but by default the fxb importer rescales each object in inches, causes some troubles with shadows (I don't know blender, but the fxb impoter may work the same way)

              Hope it helps
              Nico

              Comment


                #8
                Originally posted by Noiling View Post
                Thank you for your extensive reply.

                My current lightmap resolution is 512, if I increase it to 1024 it gets a bit better but as it is mentioned in the lightning guide being a brute force method, I would like to find another way. Attached please find the UV map, which probably will be the reason for the inaccuracies as you said.

                I am not 100 percent sure if the UV layout is setup properly. 'Snap to pixel' is activated, left a 2 pixel frame around the layout and tried to keep the relative size of each piece.

                In case you need the blend. file, please let me know. My last try would be splitting up the mesh.


                [ATTACH=CONFIG]28652[/ATTACH]
                I can tell you looking at those UV that there is nowhere near enough bleed room between your UV islands.
                James Brad Barnette
                Senior Creative Artist
                3Dmotif LLC

                Comment


                  #9
                  @Nico: Thats true but I considered that fact and multiplied the size by 100 inside the export tool

                  @James: If I zoom in as much as possible, I can see 2 little boxes. Aren't these pixels or am I mistaken here? Thanks for your help

                  Click image for larger version

Name:	UVmap2.png
Views:	1
Size:	263.2 KB
ID:	1068092

                  Comment


                    #10
                    I know pushing this thread is annoying but I want to know this so bad

                    Comment


                      #11
                      Maybe just use a higher lightmap res? Your mesh looks pretty big so I think that is logical that you need a high lightmap res.

                      Comment


                        #12
                        It might be an obvious suggestion, but did you try to reduce the static lighting level scale parameter of the lightmass ?

                        Comment


                          #13
                          I tried increasing the lightmap res to 1024 and simultaneously lowered the static lighting level scale. None of it fixed my problem. Has to be something with my blender setup

                          Comment


                            #14
                            If you are snapping a lightmap uv to grid, you need to do the power of 2 minus 2, so 1024 should be 1022x1022, or 510x510.

                            Comment

                            Working...
                            X