Announcement

Collapse
No announcement yet.

Apex Cloth rendering issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Apex Cloth rendering issues

    Hi,
    I'm trying to create an Apex cloth jacket (still WIP), I'm noticing some texture swimming and weird render artifacts as the cloth moves. (Video)
    I'm using a simple material (diffuse, roughness and normal maps), and nothing special going on with post processing.
    does anyone have a clue why this is happening? are there any ways to fix this?
    Thanks.

    #2
    Aside from the initial movement I didn't see that much "swimming" going on. Looks like you're using a translucent material as well.

    Can you tell me if this is happening if you use a material that is just the same but not with vertical lines in it? You can try any other pattern. Just want to narrow down the vertical lines part, because that could be a little bit of Moire pattern artifacts going on.
    Tim Hobson | Learning Resources | Epic Games
    UE4 Documentation

    Comment


      #3
      Hi Tim, I'm actually using a default lit material with only Base color, roughness and normal maps plugged in, the translucent effect is another thing I'm wondering about.
      I'll try another pattern tomorrow and report back.

      Comment


        #4
        My guess would be that Apex simulated cloth doesn't properly update the motion vectors, combined with temporal AA. This issue also happens with animated world position offsets.

        Change to another AA method to find out whether that is the case here.

        Comment

        Working...
        X