Announcement

Collapse
No announcement yet.

Substance to UE4 Issue - Black metal in UE4 Viewport

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Can you show us the normal map texture inside Unreal? I want to rule out poor execution; sometimes normal maps that are generated quickly from photos are really noisy, or people crank up their contrast too much. Also, is it compressed with the default normal map settings, like turning off sRGB, compressing with TC_NormalMap, etc?

    Leave a comment:


  • replied
    Ohoy again!

    I've got another small issue I've noticed, this time related to the normal map. In UE4 the normal map, when appled to the wood material of the door, har a lot of artifacts in it, taking away a lot of the detail form the base color map. The normal map is set at 2k, which I think shouldn't make it appear so jagged. Could this be because of the lighting or was the normal map not exported correctly perhaps?

    Without normal

    Click image for larger version

Name:	BbkuWfU.jpg
Views:	1
Size:	89.3 KB
ID:	1065938


    With normal

    Click image for larger version

Name:	hr5rr6o.jpg
Views:	1
Size:	99.1 KB
ID:	1065939

    Leave a comment:


  • replied
    glad it worked for you

    Leave a comment:


  • replied
    Ah, yes, seems like that was the problem. Adding a Sphere Reflection actor made the metal behave more like actual metal, thanks a bunch.

    Leave a comment:


  • replied
    Yep, metals depend on good reflections for their appearance. The material editor has a cubemap built in.

    Leave a comment:


  • replied
    have you added a reflection capture actor to your scene? I had an issue like this a while ago and that was the cause, might help might not.

    Leave a comment:


  • started a topic Substance to UE4 Issue - Black metal in UE4 Viewport

    Substance to UE4 Issue - Black metal in UE4 Viewport

    Hey,

    I've got a bit of an issue importing my Substance materials into UE4. The materials import as they should, with the exception of colors being a little off, which has no doubt something to do with the lighting. However my metallic material shows up as black in the viewport, it looks fine in the material editor but not in the viewport or when I hit play. I'm not sure if this is an issue with Substance Designer, UE4 or both, but I figure that since the material looks right in the material editor it's not completely wrong when published from Designer.

    Does anyone have a clue what the issue might be? I've checked to make sure that all greyscale images don't have sRGB checked and vice versa.

    In Designer

    Click image for larger version

Name:	ri8sxZJ.png
Views:	1
Size:	319.8 KB
ID:	1143668

    In UE4

    Click image for larger version

Name:	Wz3vmaS.jpg
Views:	1
Size:	243.1 KB
ID:	1143670
    Attached Files
Working...
X