Announcement

Collapse
No announcement yet.

Fog viewable in editor, but not in play mode?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Fog viewable in editor, but not in play mode?

    Hey guys,

    Bit of a newbie question, but perhaps we've missed something easy in our settings? In our editor the fog displays correctly, but when we hit 'play' the fog effect disappears. What have we missed? Just attached some images to show our settings and a comparison of being in the editor and being in-game:







    Really appreciate any help guys

    #2
    Is it just happening in one special level or also in other ones -> like the example map? What else do you have in your scene + which lights and engine version do you use?
    Last edited by fighter5347; 01-05-2015, 07:44 AM.

    Comment


      #3
      Hey man, thanks for replying! I'm using 4.6 at the moment. Below are the light specs I'm using, which I'm fairly sure are pretty much unchanged from the default settings:
      Click image for larger version

Name:	Lighting1.png
Views:	1
Size:	49.4 KB
ID:	1064856
      Click image for larger version

Name:	Lighting2.png
Views:	1
Size:	50.7 KB
ID:	1064857
      As for other levels, I'm not sure what you mean? I don't have any other levels currently, and the example map doesn't have the fog we put in. Currently the level is more or less a flat plane with the generic sand texture, some rocks we've modelled, our character, the atmospheric fog and the standard sky(altered in color) and light source.

      Comment


        #4
        Originally posted by Arvemor View Post
        As for other levels, I'm not sure what you mean? I don't have any other levels currently, and the example map doesn't have the fog we put in. Currently the level is more or less a flat plane with the generic sand texture, some rocks we've modelled, our character, the atmospheric fog and the standard sky(altered in color) and light source.
        What happens when you use such a fog setup in the example map? -> then we know if it's a level specific problem or a general one

        + set your light to "moveable" and check what happens

        Comment


          #5
          Cool, thanks for elaborating... I did what you said, and changed it to moveable but didn't notice any difference. I also added it into the example map and in play mode it works fine... I'm guessing then it must be something in my level that I've put in. Would a skybox affect it at all?

          Edit: Nomygod. I figured out I had two skyboxes... whilst they were both exactly the same, when I deleted one, the fog became viewable in play mode... Not sure what happened there, but thanks heaps for your help, Fighter!
          Last edited by Arvemor; 01-05-2015, 05:51 PM.

          Comment


            #6
            I know this thread is old , but I have exactly the opposite issue. local volumetric fog does not show in the editor , but shows only when I click play . Which makes it difficult to place fog locations. any ideas? thanx , also I noticed if I use "simulate" , I can then see the fog border line, but when I move the gizmo , the fog does not move with it.
            Last edited by razmaz51; 06-21-2019, 11:01 PM.

            Comment


              #7
              also if I want to keep the fog close to the ground , I cannot enlarge the fog actor just along the ground. if I enlarge any axis , it enlarges all axis's. Also even when it is by the ground , as the character moves , there is a lot of up and down movement in the fog itself.
              Last edited by razmaz51; 06-22-2019, 12:21 AM.

              Comment

              Working...
              X