Announcement

Collapse
No announcement yet.

Incorrect UV Mapping from Voxel program

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Incorrect UV Mapping from Voxel program

    I'm new to modelling / UV mapping and am having some problems getting correct UV lightmaps for my objects. I am exporting my models from a program called Qubicle (in OBJ format) which can generate the textures in a couple of different ways, but the only way to get them to have padding around the texture materials is using the settings as shown in the image attached.

    I've tried quite a few different variations over the last few days, and I am beginning to think that the UV unwrapping is just not being done in a way that UE likes (it is automatic which may be the problem). Allowing UE to create the lightmaps on a second UV layer also yields similar results.

    Bumping the lightmap resolution up to 512 seems to help a lot, but I'm not sure of the implications of having many objects with this res in the level. This also seems high for very basic meshes, and still doesn't look perfect.

    The lighting looks perfect in editor before I build it - is there an easy way to just have it use that?! I also ideally want to have very sharp shadows - i.e. no rounded or fuzzy edges, or translucent gradients. Not going for realism here.

    Thanks for any help,

    Doug
    Attached Files

    #2
    You can either make UV mapping manually in some 3d app like blender or make custom shader that does not need uv mapping. If you plan to have static lighting on those meshes there is no escape from fixing those models in blender or max/maya.

    Or you can make material that uses world space uv maps, or applies colors to surfaces based on world normal face normal. But thins method will make impossible to get correct static shadows, AO etc.

    PS. from pictures it looks like you also have wrong smoothing groups.
    Last edited by Nawrot; 12-09-2014, 01:53 PM.

    Comment


      #3
      Thanks, I will have another go at creating UVs with smoothing groups in blender.

      Comment


        #4
        Doesn't seem to matter how I generate my UVs I still get smooth shading across my faces. Is there a way to have very simple static lighting? for example hard shadows on every face of my voxel like model. This is an example of the style I'm going for: http://cdn.toucharcade.com/wp-conten...ssy-Road-1.jpg

        Is this possible in UE?

        Comment


          #5
          Ahh, yes there is, and its quite less work than uv mapping it all. Look for fake light material, (topic quite popular this week, you probably can find somebody who will share graph). make all surfaces unlit, tell meshes to cast shadows, and make that material. Turn off lightmass (ie. baked static light stuff).

          Contact author of that topic, he offered to share material. fake light material
          Last edited by Nawrot; 12-11-2014, 06:16 AM.

          Comment


            #6
            Thanks I'll look into that, unfortunately my lack of understanding when it comes to materials doesn't help!

            Comment

            Working...
            X