Announcement

Collapse
No announcement yet.

Building Lights errors on simple environment

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Building Lights errors on simple environment

    Well this is confusing.

    Click image for larger version

Name:	CfVkxDA.png
Views:	1
Size:	916.4 KB
ID:	1141392

    Before building, you can see my corridoor is lit as it should with a static point light. Yet after building it's blacked out. YET, in the error list the corridor is not even mentioned while bedroom is

    I looked into the error of "Static Mesh Actor has NULL StaticMesh property" on the official site and it says;



    This warning is caused when there is a Static Mesh Actor in a level with a NULL StaticMesh property. This can be a problem because the Actor exists and is using memory, but does not have a Atatic Mesh to actually draw. This warning is usually the result of creating a StaticMesh Actor without first selecting a StaticMesh in the generic browser. This warning can be fixed by first selecting a Static Mesh in the generic browser and then going to the StaticMesh Actor's Property Window->StaticMeshActor Category->StaticMeshComponent->StaticMeshComponent Category to set the 'StaticMesh' Property.
    I *think* they mean the property where you select the static mesh in the component right?

    Click image for larger version

Name:	vc68JRs.png
Views:	1
Size:	11.8 KB
ID:	1141393

    I'm doing exactly the same as the other environment pieces and they get no errors. I've created a perfectly simple lightmap in UV1 (not UV0) yet it's complaining about that also. All I'm doing here is exporting a FBX into my environment folder and then right clicking and creating a blue print from it.

    Please does anyone have any ideas on how to possibly fix any of these errors?

    #2
    Is your second screenshot (the one with the Static mesh property) really from the Actor named "Bedroom_Shell_3"? I think you just have a second actor in your scene that does not have a static mesh set, thus being invisible and causing this warning. And the actor from the screenshot with the static mesh set, is another one different from "Bedroom_Shell_3", isn't it?
    Guido Lein
    Technical Artist - LeFx www.lefx.de

    Comment


      #3
      Yeah it seemed to be using 2 different versions, have now made just one version and it no longer appears in the error log so thanks. Initial issue of the coriddor not lighting properly remains, why would that be resulting in black walls?

      Comment


        #4
        Make sure your static mesh has the correct UV channel set to be used for lightmaps, it's the Lightmap Coordinate Index in the static mesh editor.

        As for the other issue, that means there's a Static Mesh object in the scene that doesn't have a mesh from the content browser applied to it, so it doesn't have anything to render.

        Comment


          #5
          They were set to 0 so I changed them to 1, saved them but am still getting the same results. They 100% have a LM on UV 1, have checked in the editor and it's clearly there

          Comment


            #6
            From screenshot I am assuming that you have a single sided wall if yes! Then try to give your wall mesh some kind of thickness and try also to space out UVs.

            Comment


              #7
              Uvs are fine. Material is double sided (added a new material and made sure) Surely the mesh not being double sided isn't an issue, have never created double sided walls before. Unless this in a new rule for Unreal4?

              edit : I mean look at this, I add a direction light and the floor is illuminated but not the walls? Yet they all use the same material.

              Click image for larger version

Name:	CFDzOWU.png
Views:	1
Size:	365.8 KB
ID:	1061640
              Last edited by Adam Capone; 12-02-2014, 09:09 PM.

              Comment


                #8
                - To get best results out of static lighting, you should have some kind of thickness in your wall mesh. Never work with planes unless you don't have any second option.

                - Also check if you have lightmass importance volume in your scene for static lighting

                - Check this post out for more information regarding some common issues for static lighting bakes (https://forums.unrealengine.com/show...ghting-Problem)

                Originally posted by Adam Capone View Post
                Uvs are fine. Material is double sided (added a new material and made sure) Surely the mesh not being double sided isn't an issue, have never created double sided walls before. Unless this in a new rule for Unreal4?

                edit : I mean look at this, I add a direction light and the floor is illuminated but not the walls? Yet they all use the same material.

                [ATTACH=CONFIG]18642[/ATTACH]

                Comment


                  #9
                  1) I've never come across an engine that needs you to build double sided polys even if they are not to be seen by the player. Regardless, I've gone and done that to the coridoor piece. Here is the light map;

                  Click image for larger version

Name:	ExvNINw.png
Views:	1
Size:	622.6 KB
ID:	1061673

                  2) Added a lightmass importance volume

                  3) The example you provided has some good information though it's more about a weak looking lightmap. My problem isn't a weak looking light map with seams etc, it's just not working. I'm guessing it has nothing to do with lightmaps even. Anyway, I put up indirect lighting quality to 4 and smoothness to 0.6. Didn't work.

                  One step at a time. Why is this happening in the viewport? I believe this is the key to the problem here as I've not experienced it before. This isn't normal is it? Why does my wall only pick up light after moving the source?

                  Click image for larger version

Name:	VjC4iU1.png
Views:	1
Size:	388.6 KB
ID:	1061675

                  Comment


                    #10
                    There is a problem in UE4 when you first import the mesh while it doesnt have second UV channel, and after you fixed it and added second UV and reimported it still has problems.
                    The solution is rename old mesh or import new mesh with different name.(not reimport) and click objects in map and change mesh pointers to newly imported mesh and delete the old one.
                    https://canerozdemirportfolio.wordpress.com

                    Comment


                      #11
                      Originally posted by caner_ozdemir View Post
                      There is a problem in UE4 when you first import the mesh while it doesnt have second UV channel, and after you fixed it and added second UV and reimported it still has problems.
                      The solution is rename old mesh or import new mesh with different name.(not reimport) and click objects in map and change mesh pointers to newly imported mesh and delete the old one.
                      It may be a complication with auto generating second UV's during import. There is a tickbox for it in import dialog box that you may want to disable if you want to use your custom second UV channel.
                      FREE VR Drum Kit Project
                      FREE Color LUT Collection
                      FREE Physics Driven Spacecraft Project
                      FREE GTA Style Vehicle Interaction
                      Dynamic DoF(Depth of Field)
                      Camera Crossfade

                      Comment


                        #12
                        Hi,

                        When you import a mesh with only one UV channel (for the texture), UE uses that also as lightmap index.
                        When you add a second UV set for the lightmap and reimport the mesh, the mesh is reimported with both channels, but the property in the detauils panel still points to your old lightmap channel.
                        So no need to delete and reimport, just change that value from 0 to 1....

                        Cheers,
                        Klaus

                        Comment


                          #13
                          Camer, yep, think that's my only remaining option now. Will try it.

                          Jacky, I can't see a tickbox in the import dialog (when importing a static mesh) for lightmaps?

                          Kvogler, it's not this. I've made sure that my static meshes ligthmaps are set to 1 instead of 0 and the problem persists.

                          Comment


                            #14
                            Generate Lightmap UVs is the name of the tick box. Click the white arrow to extend Mesh tab if you cant see it. This is integrated with 4.5, btw, in case you have an earlier version of the engine.
                            FREE VR Drum Kit Project
                            FREE Color LUT Collection
                            FREE Physics Driven Spacecraft Project
                            FREE GTA Style Vehicle Interaction
                            Dynamic DoF(Depth of Field)
                            Camera Crossfade

                            Comment


                              #15
                              I have the latest version and yet I have no such options

                              Click image for larger version

Name:	Fn0HtLY.png
Views:	1
Size:	73.3 KB
ID:	1061701

                              Comment

                              Working...
                              X