Announcement

Collapse
No announcement yet.

Washed out Colors from Tone Mapping: How bad it really is, and how to fix it

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by Tuxmask75 View Post
    4-Kay Man! (Okay Man!)( sorry for the double post,,,) try this:
    The disable tone mapping does not work in packaged game.... so I figured something else out which works in a Packaged build of the game. (wish it were more simple than this, but ehhh)
    Check this **** out ! ! ! And let me know if it woks for you and with your colors.
    r.TonemapperGamma 0
    r.TonemapperFilm 0
    r.Tonemapper.Quality 0


    my test BP:
    While this looks better, it still alters my colors and doesn't look as good as completely disabling the tonemapper.

    Why is it impossible to import a texture with X color values and actually display those exact values? You can't even display a texture with just 255,255,255 you will end up with 242,242,242. This is maddening.
    Last edited by JayRockets; 08-19-2019, 10:47 AM.

    Leave a comment:


  • replied
    4-Kay Man! (Okay Man!)( sorry for the double post,,,) try this:

    The disable tone mapping does not work in packaged game.... so I figured something else out which works in a Packaged build of the game. (wish it were more simple than this, but ehhh)
    Check this **** out ! ! ! And let me know if it woks for you and with your colors.

    r.TonemapperGamma 0
    r.TonemapperFilm 0
    r.Tonemapper.Quality 0


    my test BP:
    Attached Files

    Leave a comment:


  • replied
    Sigh,, I agree...……

    Leave a comment:


  • replied
    Yeah this really needs to get fixed. The only solution I've been able to come up with is to just manually adjust the tonemapper settings for each scene. There has to be a better way!

    Leave a comment:


  • replied
    And after four years, still no solution. Thank you.

    Leave a comment:


  • replied
    Well for starters it completely disables anti aliasing in the forward renderer, so that's simply not an option.

    And I'm not asking for the default tonemapper to change, I just want a nice and convenient button somewhere along the lines of "Stop ****ing up my colours"

    Leave a comment:


  • replied
    Maybe you just have to bite the bullet and turn off the tonemapper and go through each problem that causes and see if you can fix or work around?
    What are the resulting problems that you get?

    I imagine if Unreal suddenly changed the behaviour of the tonemapper then a lot of people would be upset by that as well as they have now tuned their games to look like they want.

    Leave a comment:


  • replied
    I desperately need a fix for this, I'm using handpainted textures and need the colours to actually match what I paint. When importing my colours into the engine they look just awefull, and nothing else but turning off the tonemapper takes care of the issue, however turning off the tonemapper comes with its own list of problems that I really want to avoid.

    Here's a link to a facebook post detailing the issue.

    https://www.facebook.com/groups/ue4d...9104716287896/

    And no, screwing with tonemapper settings isn't fixing it.
    No, screwing with texture settings isn't fixing it.
    "It makes your textures pop more" - I don't want that, I carefully author my textures to pop where they need to pop, I don't want the engine to guess this stuff for me.

    I understand that it is intended behaviour, but this intended behaviour makes working with certain artstyles completely impossible inside of UE4, just give me a switch to turn this mess off.

    Leave a comment:


  • replied
    Sorry for double post. but I got a solution to the tone mapper. Check it out !
    https://forums.unrealengine.com/show...-completly-or-!

    Also I wonder if there is a sweet spot for setting up color grading and tone mapper to where we can get a default non tone mapper look and feel. so that we can still use the tone mapper in specific cases !
    Has anyone actually attempted that here? playing with the post process settings in search for the sweet spot?

    Leave a comment:


  • replied
    Originally posted by SimplyMark View Post
    Can you please elaborate?
    So I set up a new material, set it to Replace the Tonemapper, Create a Post Process Volume, Assign previously created material to Blendables...
    Then what? How do I make this new material in the Post Process Volume to display image unaltered by the Tonemapper?
    Or am I misunderstanding something?
    I would really like to know how to do this as well!

    Leave a comment:


  • replied
    Show some picture. I can't think any possible mechanism to turn totally unlit scene to gray.

    Leave a comment:


  • replied
    Hows this going? i cant believe ts even a thing.

    Leave a comment:


  • replied
    Has this been fixed yet?

    Leave a comment:


  • replied
    Originally posted by Jenny Gore View Post
    If you make post process material you can set it to replace tonemapper. Then you just put that as Blendable to Post process volume.
    Can you please elaborate?
    So I set up a new material, set it to Replace the Tonemapper, Create a Post Process Volume, Assign previously created material to Blendables...
    Then what? How do I make this new material in the Post Process Volume to display image unaltered by the Tonemapper?
    Or am I misunderstanding something?

    Leave a comment:


  • replied
    Originally posted by megalomanium View Post
    Er, yes, it does. There aren't any settings in the post-process volume that fix the color distortion, as far as I'm aware, and the only way to disable tone mapping fully (last I checked) was using a debug flag in the Editor that doesn't exist in runtime. You've got to do the UE4 shader change that the OP mentions to actually disable it and make the colors accurate.

    If that's changed in the last year, by all means, I'd love to know how - but so far as I'm aware, it has not.
    If you make post process material you can set it to replace tonemapper. Then you just put that as Blendable to Post process volume.

    Leave a comment:

Working...
X