Announcement

Collapse
No announcement yet.

Help with lightmaps? (Probably a n00b question)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Help with lightmaps? (Probably a n00b question)

    Hi all -

    I'm working on my first little environment piece, and I'm having an issue with baking lightmaps, I keep getting an "Lightmap UVs are overlapping by 86.5%" error even if I select a different UV set for the light mapping process to use. Help? This is my first project in Unreal, so I'm definitely still learning!

    This is what the version with the lights built looks like :/

    Click image for larger version

Name:	mVUTtri.png
Views:	1
Size:	168.8 KB
ID:	1140351

    Imgur album with more images and description/screenshots here:

    http://imgur.com/a/OjlIP

    The weirdest part to me is that I keep getting the 86.5% error, even if I select a different UV map to be used. It makes me wonder if I'm not correctly telling the engine which map I want to use for baking the lightmaps?

    #2
    You should create a second UV channel for your mesh and set correct lightmap UV. To find out what is lightmap UV and how it looks, visit this link: https://docs.unrealengine.com/latest...ing/index.html

    If you have 4.5.x version of engine, it has built-in lightmap UV generator. Open mesh in mesh editor, and there tick generate Lightmap UV

    Comment


      #3
      Hi Wozner - I generated a lightmap UV, or so I thought? It's shown here: http://i.imgur.com/jtHB246.png and I used the Unreal unique map generation tool. (I have 4.4)

      Comment


        #4
        That looks right. Now filter the detail settings by "Index" and change the lightmap index to "1". If you get multiple field results, it's always the last field. Then rebuild your lighting.

        You can check how many UV channels you have using the dropdown that says "UV Channel 1". In this case your UV generation settings created a new UV channel for you, which is what you wanted.

        Nice tree by the way.
        Last edited by Antidamage; 11-02-2014, 09:49 PM.

        Comment


          #5
          Originally posted by Antidamage View Post
          That looks right. Now filter the detail settings by "Index" and change the lightmap index to "1". If you get multiple field results, it's always the last field. Then rebuild your lighting.

          You can check how many UV channels you have using the dropdown that says "UV Channel 1". In this case your UV generation settings created a new UV channel for you, which is what you wanted.

          Nice tree by the way.
          Just tried it out, and yup - this is the step I was missing! Thank you so much.

          Comment


            #6
            Well from that image it looks correct, you have two lightmap channels and all. Seems to be enough padding between the islands too but you can also see were the triangles crunch up together (which might be where the overlap is happening). You can manually make your own lightmaps though, which 3D program did you make the tree in? Chances are you can make your lightmaps there already.

            And as a side note, the auto UV generation in 4.4 is inferior to the one 4.5+. They revamped it and it's much better now, so if you can update your engine then do so

            Comment


              #7
              While you're at it, the other thing I normally do at this stage is set the lightmap resolution. It's often lower than what I'd like. I forget what the setting is but it's also in that particular pane.

              Comment


                #8
                Thanks all - I actually had made lightmaps in Maya first, but I thought maybe that was the issue so I tried out Unreal's generator. I will probably go back to the ones I made because I think they'll work better. (I'm not able to upgrade at the moment.) I'd also experimented with switching up the lightmap resolution but that didn't solve my issue - now that I have that fixed, will probably go back and check out the resolution.

                Looks like I just didn't have that setting correct that Antidamage told me about!

                Comment

                Working...
                X