Announcement

Collapse
No announcement yet.

Distance fields mesh problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Distance fields mesh problem

    i have a problem with distant field meshes. let me explain.

    i want to use the new ray traced shadows in my test scene.
    this is my room walls mesh. very small room, very simple mesh. only 96 triangles.
    Click image for larger version

Name:	6tIbgZISLIDEb3nA0O1j75esDHxPG.jpg
Views:	1
Size:	145.7 KB
ID:	1140231

    i set the distance field resolution scale on max, 100 but the distance field mesh is unacceptable. holes everywhere. its unusable.
    i scale it down to 30% of the original size but there's absolutely no change.
    this is how it looks like:
    Click image for larger version

Name:	6tIbMRYLJ3gqqma9xDStS0W7EgjVF.jpg
Views:	1
Size:	143.3 KB
ID:	1140232

    i tested the default lamp mesh. it has 2000+ triangles i scaled it way way up so its bigger than my room and yet it has a perfect distant field mesh
    Click image for larger version

Name:	6tIbRQHKxatVmsM6DOQmATjCFU63B.jpg
Views:	1
Size:	109.7 KB
ID:	1140233 Click image for larger version

Name:	6tIbPqTs3abEjI7zX6xLpE9ZLkDgq.jpg
Views:	1
Size:	26.0 KB
ID:	1140234

    how does this work? how can i fix this?

    #2
    Break up your mesh into multiple objects. The distance field generation doesn't work well for this kinds of hollowed meshes. You are always better off using separate meshes for each wall, floor and ceiling instead of a one-room mesh.
    3.14159265359

    Comment


      #3
      breaking it up on down to separate wall meshes is not really an option, there would be problems with seams in corners and texturing it one by one would be a pain in the ***.

      but ill try to make it more solid, double walls, closed mesh and will see...

      Comment


        #4
        Originally posted by jazvecina View Post
        breaking it up on down to separate wall meshes is not really an option, there would be problems with seams in corners and texturing it one by one would be a pain in the ***.

        but ill try to make it more solid, double walls, closed mesh and will see...
        You'd be far better off by just using separate meshes for the walls. Use pillars or some trimming to mask the seams.

        Comment


          #5
          I have same problem.
          It is Limitations of Distance Field:

          Limitations of the current implementation (can be improved in the future)
          Large objects will have poor distance field resolution and cause poor AO quality, as a volume texture is mapped to each mesh.
          (https://docs.unrealengine.com/latest...ion/index.html)

          Comment

          Working...
          X