Announcement

Collapse
No announcement yet.

Lights doesn't make a nice result on my meshes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Lights doesn't make a nice result on my meshes

    Hi,

    i have done several Meshes in Blender and imported from UDK as FBX.
    I have created the second UV channel because when i Build the light, all the meshes became black.
    Now, after build the lights in the world, i can see the materials on the meshes but the result is not good for i want.

    All my meshes haven't textures and they were painted in basic material colours.

    i sent two images, one with the ligght build and other didn't. I want to get the second image efect with the simple colours and smooth shadows but, in the first image, where the lights are built, the stairs, by example, i can see triangles of shadows and i don't like this cut effects.
    How can i build the lights and get the smooth shadows between my meshes?.
    The meshes are very simple, in low polly, and shouldn't have this triangles cuts of shadows, i think...
    Attached Files

    #2
    Can you post the UVs? Are you using 4.5?

    Comment


      #3
      -increase the lightmap resolution of your meshes
      -add a lightmass importance volume
      -post a pic of your uv's

      Comment


        #4
        hi guys,

        the version is 4.4.3

        and this is the UV generated by UDK4 mesh properties:

        Click image for larger version

Name:	UV_Stairs.png
Views:	1
Size:	319.5 KB
ID:	1060220

        i don't know if there are another way to generate this UV in the UDK editor... I tryed to make the UV from Blender but the result is the same.
        I would like to know if there are a way to simplify the build light process because i would like to get a ver smooth result of shadows... not sofisticated.

        My project is a third person code project... so i have a lightmass volume on my all assets.
        the ligmtmap resolution? how can i change this option... i just try the 3 options of build lights: Preview, high and production mode, but the result is the same.

        Comment


          #5
          You can increase the lightmap resolution in the static mesh editor. Take a look at this thread, probably it will solve your problem: https://forums.unrealengine.com/show...porting-models

          "Double click onto your static mesh in the UE4 -> Select the recompute tangents/normals and click save "

          Comment


            #6
            i have revised the check of the recompute tangents and is selected... i have checked the normal and the full uv precission too... but still shows the triangulized shadows...

            the UV of the mesh was created by the udk4 static mesh editor so i should think the problem is not here...
            I like the visual effect from the first image... when i put the asset in the world before build lights... so is there any option to build the lights keeping this smooth global shadow?

            Comment


              #7
              You are facing that artifacts because of bad lightmap UV's. In blender do a second UV channel for Lightmaps and flatten your UV's under 45 degree, that should solve the problem.

              Comment


                #8
                Originally posted by Wozner View Post
                You are facing that artifacts because of bad lightmap UV's. In blender do a second UV channel for Lightmaps and flatten your UV's under 45 degree, that should solve the problem.
                MMm... so the problem was the UV's ... they were created in the udk 4 static mesh editor... i thouhgt the engine created this UV well...

                so if i need to do it in Blender... can you explain me more what de you mean with flatten my UV 45 degree?... if you know some especific tutorial... i have no idea how can i do a good UV in Blender for my meshes...
                thanks

                Comment


                  #9
                  Not the best way how you can create a lightmap, but it works: https://www.youtube.com/watch?v=z5yc-bKbHyc

                  http://www.worldofleveldesign.com/ca...el-in-maya.php

                  Comment


                    #10
                    This tutorial should help you to get comfortable with UV's in blender: https://www.youtube.com/watch?v=f2-FfB9kRmE

                    Comment

                    Working...
                    X