Announcement

Collapse
No announcement yet.

How to fix dark backfaces on Grass?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    How to fix dark backfaces on Grass?

    I would like to create a Grass material with a simple color and an opacity mask.
    The faces somehow have different lighting and are darkened on the backfaces.

    The normals have been edited to face in a 80° angle upwards, that still does not solve the issue.
    How can i fix this?


    #2
    check this Thread
    https://forums.unrealengine.com/show...ronment-in-UE4
    reference
    http://dirty-windows.de

    my blog
    http://ulrichthuemmler.blogspot.com/

    Comment


      #3
      Thanks Ulrich,

      i already read your entire blog + the link and your ideas in there, but somehow i can't get rid of the darkened backfaces.

      Adding a vector facing up (0,0,1) as a fixed Normal in the material editor (Tangent Space Normal disabled) is indeed a workaround, but prevents me still from using my custom normals which are slightly rotated.
      I then tried to disabled "two sided" and created two faces for every side, just like Michal suggested in his blog.
      With the double sided version, i added my material and the entire mesh was invisible. Strange error.

      Getting pretty late here, so i have to try again tomorrow, thanks in advance and greetings from Bremerhaven

      Comment


        #4
        If you can set the vertex normals to face up on the mesh before importing to UE4, would that be a good solution? I believe setting the normals up in the material would cause batches of foliage to all contain the same shading, and not look as smooth as if all the normals were facing up and each part of each mesh was rendered with the full breadth of lighting. I haven't messed with foliage much in UE4. Should probably try doing that sometime.

        Comment

        Working...
        X