Announcement

Collapse
No announcement yet.

transparency sorting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    transparency sorting

    Hi,
    I know this has been tackled a few times but Im still having issues an was wondering if anyone had additional insight

    *Im making a short film so this needs to work in the sequencer

    I have a scene with some FG ground fog (Niagara with sprite cards) and in the sky, far in the distance I have a meteor falling (also Niagara sprites). the idea is we see it in the clear sky, but as it gets closer to the ground it vanishes behind this fog.

    Ive set the FG fog to 100 in the Translucency Sort Priority and the meteor to 0. This has worked fine, ordering the meteor behind the fog. But as Ive worked on the shader it seems to have broken.
    When I swap the shader (with some other clouds shaders I have) it works, but some others it doesnt.
    Ive tried killing the Emission of the shader (which I need, but it doesnt work anyway)
    and Ive looked thru the shaders for clues as to what might be causing this, but havent found anything and havent found any information regarding materials and trans sorting (that seems relevant) specifically.

    Any suggestions? Am I even on the right track assuming its material based?

    Thanks in advance


    #2
    It sounds like a translucency sorting issue, though it could be something else entirely. The clouds shaders that it doesn't work for...what are the differences in those compared to the FG fog and working cloud shaders? I'd start there. There's also post processing, which could be interfering with the correct order.

    Comment


      #3
      Thanks Presto423 for your suggestion, I actually had just found after comparing 2 shaders (as youre suggesting)
      I found Render After DOF checkbox is by default on. Turning it of has fix the ordering. Would not have guessed it.
      So DOF can effect the transparency sorting. Thats good to know

      Comment


        #4
        Hmm, that'd imply that depth of field is activated in the scene somewhere. Or there's blurring happening in one of those shaders.

        Comment


          #5
          I do have some very subtle DOF in the scene.

          Comment

          Working...
          X