Announcement

Collapse
No announcement yet.

Generating lightmaps results in splotches and visual artifacts. Helpp :)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Generating lightmaps results in splotches and visual artifacts. Helpp :)

    Hi :-)

    I am having some particularly annoying issues when generating lightmaps for my interior scene.
    You can see the blurry spots and strange artifacts that I am receiving in the image links below.

    https://imgur.com/IaD9zqZ
    https://imgur.com/XWm6h3u
    https://imgur.com/Fev3dKV

    The selected static mesh in the first image listed above has it's 'Lightmap resolution override' set to 1024. I have experimented with a few different resolutions on all objects but there is always some of these artifacts no matter what resolution I try (mind the fact that I haven't tried too many resolutions as each build takes quite some time.)

    ----------------------------------------

    In the two image links below you can see the UV maps for the same wall/stair block shown previously. The first map is used for texture mapping, and the second UV map selected is for lightmap generation (as shown in the right pane; Coordinate Index). So, I don't believe my issues relate to any of my UV mappings.

    https://imgur.com/HGBLhfq
    https://imgur.com/4Q9Bigz

    Also, I have tried generating lightmaps in the Medium, High, and Production settings with the same/similar results, and yes, I use a lightmass import. volume... Any more help, or tips, are much appreciated :-)

    Thanks, J.

    #2
    What are the skylight settings?

    Comment


      #3
      Hi!

      Your quality setting, under lightmass is too low! You don't get enough samples and that's why you're experiencing those artifacts! /or go higher with level scale, depends what quality you're after/
      ...sometimes lights that intersecting transparent materials or just objects can cause similar results...
      Some other things: you should turn off lightmass compression if you want to achieve better results!
      Try to break up your meshes into smaller parts because you'll run into a scenario where the result is still not clean enough but you won't be able to raise your lightmap resolution!
      Also even for test baking use at least medium build! ...the preview is just what is says!

      Comment


        #4
        Originally posted by presto423 View Post
        What are the skylight settings?
        I am not using a skylight in this scene. :-)
        Originally posted by Makigirl View Post
        Hi!

        Your quality setting, under lightmass is too low! You don't get enough samples and that's why you're experiencing those artifacts! /or go higher with level scale, depends what quality you're after/
        ...sometimes lights that intersecting transparent materials or just objects can cause similar results...
        Some other things: you should turn off lightmass compression if you want to achieve better results!
        Try to break up your meshes into smaller parts because you'll run into a scenario where the result is still not clean enough but you won't be able to raise your lightmap resolution!
        Also even for test baking use at least medium build! ...the preview is just what is says!
        Thanks for the tips!

        I am trying a new build with some tweaked lightmass settings, where I have disable lightmap compression, among other things.

        I'll report back with the results. Thanks, J.

        Comment


          #5
          Originally posted by Makigirl View Post
          Hi!

          Your quality setting, under lightmass is too low! You don't get enough samples and that's why you're experiencing those artifacts! /or go higher with level scale, depends what quality you're after/
          ...sometimes lights that intersecting transparent materials or just objects can cause similar results...
          Some other things: you should turn off lightmass compression if you want to achieve better results!
          Try to break up your meshes into smaller parts because you'll run into a scenario where the result is still not clean enough but you won't be able to raise your lightmap resolution!
          Also even for test baking use at least medium build! ...the preview is just what is says!

          I tried the tips you provided. It helped a lot, butttt there's still quite a lot of these artifacts in dark areas. Even with my resolution set to 1024 :c

          I am trying another build with resolution scaling set to 150% as I type.

          Completely open to any other tips; it would be appreciated. :-)

          Comment


            #6
            Could you show me screenshots? + what are your lightmass settings now?
            Ok, so if you set 1024 as lightmap resolution it doesn't mean anything!! You set your lighting map in pixels!! So if you have half of your house as one mesh than 1024 pixels won't go far....
            ...what do you mean by 150% resolution scaling?

            Comment


              #7
              There's a point to questioning whether lightmap resolution is going to fix it. To describe one aspect, if a lightmap resolution is 2048 or higher, then Lightmass is requiring more samples and possibly more lighting information (meaning a need to increase light intensity and a few other settings perchance) to properly solve results. And if LOD 0 is the only LOD used, which it is by default, then it's going to offset the overhead of memory and calculation in contrast to other parts of the scene with a lower lightmap resolution. The problem, I hypothesize for your scene's lighting, is there's a lack of indirect intensity. Since there's no skylight, you need a higher directional light intensity than a scene that has a skylight. So, try increasing directional intensity by 4x minimum and increase its Indirect Intensity (just a few settings down) to 2 or 3. It's not all based in World Lightmass settings is how I've figured out to approach static/stationary lighting. Don't worry if the shadows are not dark enough yet, or are a bit too dark because those could be modified later with a number of settings, including cvars.

              The caveat with resolution scaling is similar to increasing lightmap resolution, whereby Lightmass is needing to generate and use a ton of samples and 'rays' / cone traces to approximate the details of different meshes and materials in the scene. Keeping the resolution low to moderate (max of 512) from the start is helpful with proper settings of intensity to generate an average result that's workable. Then wherever it's really needed, increase lightmap and texture resolution, and/or other types of resolution scaling. But resolution scaling as an overarching workaround is probably going to limit output, and likely introduce other artefacts.

              Comment

              Working...
              X