Announcement

Collapse
No announcement yet.

Changing Aperture is not affecting the light

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Changing Aperture is not affecting the light

    Changing Aperture is not affecting the light even if I have manual exposure control.
    WTF is going on?

    Setup hundreds of scene files using the cinematic camera.
    For some reason.. I have a project file, changing the aperture doesn't change the lighting.

    I deleted all PPV, checked the camera.
    Created a new one.

    Nothing.

    I start a new scene file, and it works.
    What could that be?
    Any hidden project file settings?

    can't find the problem.. thank for any little hint!

    cheers



    #2
    Probably auto exposure actually being active despite you thinking otherwise.

    Easiest way to check is the auto exposure debug.
    https://docs.unrealengine.com/en-US/...ure/index.html

    Otherwise you can't really expect any help by just saying "it doesn't work here but everything is right"... we have absolutely 0 idea what your in engine settings are.

    Comment


      #3
      that's correct. What you mentioned I already checked. My question is about the project settings. If there are settings, that might overwrite the manual exposure control affecting the aperture.
      That's it. Meaning, if there is a known general option within the project settings that would overwrite everything else.
      I've never experienced this before in any other project file. Thx, cheers

      Comment


        #4
        Yes auto exposure is a setting thats on by default in all new projects.
        you have to turn it off either via post process or via project settings.
        It was changed in .25 to work differently, so maybe its taking over more aggressively than before.

        It could even be that before it was not affecting cinematic cameras, and now it does.
        forcing it off in project settings should prevent any external influence on any camera.

        If it doesn't turn off after changing project settings, maybe the post process calls for it to be on.
        Last edited by MostHost LA; 08-25-2020, 03:00 PM.

        Comment


          #5
          The Post-Process settings in a camera will overwrite whatever you have in a Post-Process Volume(or the defaults set by the project), so it doesn't really matter what's enabled in the project.

          You need to make sure you have "Game Settings" enabled in the viewport, then in the CineCamera make sure the "Apply Physical Camera Exposure" is checked(it is by default), then set the Metering Mode to "Manual." After that, ISO and Shutter Speed will be controlled in the Camera section of the Post-Process settings, but the Aperture will be controlled exclusively by the CineCamera's aperture.
          Lighting Artist @ Rockstar Games
          ArtStation
          Twitter

          Comment

          Working...
          X