Announcement

Collapse
No announcement yet.

Have some lightning issues. Please help!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Have some lightning issues. Please help!

    After light building on my foliage and also at some standalone meshes appears some strange light blobs. Also kind of this things appear on terrain. What to do? For flora I use world position, if it may be the cause. For terrain nothing special. Albedo Normal and AO. Thanx! Also I wanna ask if somebody knows why my terrain is so dark after baking. Everything around looks way brighter. Help!
    Last edited by OnixEdward; 08-02-2020, 03:11 PM.

    #2
    You might need to post screenshots of your light settings. Get the directional and skylight settings under Light, including what's under Advanced (also expand Lighting Channels under Advanced to show what channels are being used). Get the post process volume settings for Lens > Bloom, Exposure; Film; and Rendering Features > AO, RTAO, GI, RTGI, Reflections, RT Reflections, Translucency, RT Translucency; finally, Post Process Volume Settings. Using World Position for the foliage shouldn't matter in terms of the lighting and it being dark, but it could be messed up because of that and some other setting(s).

    Comment


      #3
      Originally posted by presto423 View Post
      You might need to post screenshots of your light settings. Get the directional and skylight settings under Light, including what's under Advanced (also expand Lighting Channels under Advanced to show what channels are being used). Get the post process volume settings for Lens > Bloom, Exposure; Film; and Rendering Features > AO, RTAO, GI, RTGI, Reflections, RT Reflections, Translucency, RT Translucency; finally, Post Process Volume Settings. Using World Position for the foliage shouldn't matter in terms of the lighting and it being dark, but it could be messed up because of that and some other setting(s).
      Thank you for reply! So to structure my problem more, you see on the first screen that terrain is much darker than foliage and meshes. That what I meant about terrain. Also I attach terrain bp if this could be a problem. I use only sky light in terms of performance, and it was enough for me. For PP it is pretty default. May be terrain settings also would be helpful so I attach them too.

      As for the foliage, only plant meshes have some light dots on them even if I don't use foliage tool and set them by hand. Nothing special. Imported straight from Quixel bridge. I already tried to change lightmap resolution that was mentioned in some of the topics but it didn't work. Light dots/blobs appear in same place every baking.

      Thank you for help!

      Comment


        #4
        You're welcome. Thanks for posting the screenshots of settings, and part of the terrain material graph. I'm seeing a number of things that likely are the cause(s) of the scene being dark. I'll type a list, and I think you ought to try these suggestions one by one, separately at first. Then, try them in combination, or additively one after the other. This is to see the results of changing one thing at a time, and then how the scene changes with combinations (however you choose):
        • In the post process volume (PPV), under Lighting, uncheck everything (including Cast Shadow). These settings are for the PPV itself, whether it casts a shadow (as though it was a solid object). It's probable that the current settings are darkening the entire scene because it is Unbound and casting a shadow, and affecting both Dynamic Indirect Lighting and Distance Fields. Disable all of it under Lighting.
        • Under Exposure in the PPV, change the Min and Max Brightness settings to these (Min Bright = -5.0, Max Bright = 5.0). If those don't work, decrease Min to lower (say down to -10) and Max to at the most -20. Turn on Metering Mode and select Auto Exposure Basic, and turn on Exposure Compensation and set it to between -1 to 1, preferably 0. Don't enable or change other settings for Exposure, keep only those.
        • In the PPV, under Screen Space Reflections, disable Max Roughness. Go to Reflections, and enable the checkbox. Keep it at Ray Tracing. Then go to Ray Tracing Reflections, enable all checkboxes (turn on all settings in there), and set the following:
          • Max Bounces = 3
          • Samples per pixel = 4
          • Shadows = Area Shadows
          • Keep "Include Translucency..." checked
        • In the PPV, under Translucency, select Ray Tracing. Then go to Ray Tracing Translucency, enable all settings, and set the following:
          • Samples per pixel = minimum of 4
          • Shadows = Area Shadows
          • Keep "Refraction" checked
        • In the PPV, go up to Ambient Occlusion and enable the top two settings (Intensity and Radius). See what happens with the current values, and if it's not looking right, then try increasing / decreasing the values by small amounts (0.1 per change of Intensity, and 50/100 per change to Radius). Leave Advanced settings alone for now.
        • Under Ray Tracing Ambient Occlusion (RTAO), enable both checkboxes and change Samples per Pixel to at least 3/4, but try higher too because it's a foliage and terrain scene.
        • Also in the PPV, enable Global Illumination and keep Indirect Lighting Intensity at 4, or decrease it somewhat if needed. It could need an increase if the scene is still dark, but it probably won't yield much of a result because it's indirect lighting. Each bounce after direct lighting projects a small percentage or fraction of the previous light cast with indirect lighting. Then under Ray Tracing Global Illumination, enable all settings, select Brute Force method, and set Max Bounces to at least 3, and Samples per Pixel to at least 4.
        • For the skylight:
          • Increase "Indirect Lighting Intensity" to a minimum of 0.5, but try 1 too.
          • Enable "Affect Translucent Lighting", "Transmission", and try enabling "Cast Ray Tracing Shadows" (it's optional, but it might produce better results for the ground shadows below foliage).
        • After making all those changes, click "Recapture" on the skylight. Since the skylight for HDRi is dynamic (set to movable) by default, and needs to be dynamic, you are probably encountering a problem with dynamic lighting methods / settings. Turning on ray tracing features for lighting should get it looking much better. If it doesn't work, I suggest adding a directional light and modifying its settings according to the scene's needs / intended results.
        Post back when you've tried some / all of those to say if the scene is better or not. Since you said other areas are still bright, it could also potentially be a texturing / materials issue.

        Comment


          #5
          Thank you really much, scene became more clear in terms of shadows and other. And then I figured out that are some problems with foliage. Guess it is due to translucency.

          Comment


            #6
            Originally posted by presto423 View Post
            You're welcome. Thanks for posting the screenshots of settings, and part of the terrain material graph. I'm seeing a number of things that likely are the cause(s) of the scene being dark. I'll type a list, and I think you ought to try these suggestions one by one, separately at first. Then, try them in combination, or additively one after the other. This is to see the results of changing one thing at a time, and then how the scene changes with combinations (however you choose):
            • In the post process volume (PPV), under Lighting, uncheck everything (including Cast Shadow). These settings are for the PPV itself, whether it casts a shadow (as though it was a solid object). It's probable that the current settings are darkening the entire scene because it is Unbound and casting a shadow, and affecting both Dynamic Indirect Lighting and Distance Fields. Disable all of it under Lighting.
            • Under Exposure in the PPV, change the Min and Max Brightness settings to these (Min Bright = -5.0, Max Bright = 5.0). If those don't work, decrease Min to lower (say down to -10) and Max to at the most -20. Turn on Metering Mode and select Auto Exposure Basic, and turn on Exposure Compensation and set it to between -1 to 1, preferably 0. Don't enable or change other settings for Exposure, keep only those.
            • In the PPV, under Screen Space Reflections, disable Max Roughness. Go to Reflections, and enable the checkbox. Keep it at Ray Tracing. Then go to Ray Tracing Reflections, enable all checkboxes (turn on all settings in there), and set the following:
              • Max Bounces = 3
              • Samples per pixel = 4
              • Shadows = Area Shadows
              • Keep "Include Translucency..." checked
            • In the PPV, under Translucency, select Ray Tracing. Then go to Ray Tracing Translucency, enable all settings, and set the following:
              • Samples per pixel = minimum of 4
              • Shadows = Area Shadows
              • Keep "Refraction" checked
            • In the PPV, go up to Ambient Occlusion and enable the top two settings (Intensity and Radius). See what happens with the current values, and if it's not looking right, then try increasing / decreasing the values by small amounts (0.1 per change of Intensity, and 50/100 per change to Radius). Leave Advanced settings alone for now.
            • Under Ray Tracing Ambient Occlusion (RTAO), enable both checkboxes and change Samples per Pixel to at least 3/4, but try higher too because it's a foliage and terrain scene.
            • Also in the PPV, enable Global Illumination and keep Indirect Lighting Intensity at 4, or decrease it somewhat if needed. It could need an increase if the scene is still dark, but it probably won't yield much of a result because it's indirect lighting. Each bounce after direct lighting projects a small percentage or fraction of the previous light cast with indirect lighting. Then under Ray Tracing Global Illumination, enable all settings, select Brute Force method, and set Max Bounces to at least 3, and Samples per Pixel to at least 4.
            • For the skylight:
              • Increase "Indirect Lighting Intensity" to a minimum of 0.5, but try 1 too.
              • Enable "Affect Translucent Lighting", "Transmission", and try enabling "Cast Ray Tracing Shadows" (it's optional, but it might produce better results for the ground shadows below foliage).
            • After making all those changes, click "Recapture" on the skylight. Since the skylight for HDRi is dynamic (set to movable) by default, and needs to be dynamic, you are probably encountering a problem with dynamic lighting methods / settings. Turning on ray tracing features for lighting should get it looking much better. If it doesn't work, I suggest adding a directional light and modifying its settings according to the scene's needs / intended results.
            Post back when you've tried some / all of those to say if the scene is better or not. Since you said other areas are still bright, it could also potentially be a texturing / materials issue.
            But what do you think about bright spots on objects? What could cause it?

            Comment


              #7
              What program(s) was the foliage made in?
              Are the bright spots similar in shape and intensity?

              There's quite a number of potential causes of the bright spots. Try solving one or two objects' bright spots problem, then apply those steps or the solution to other objects. Can you post a few screenshots of the bright areas / spots?

              Comment


                #8
                Originally posted by presto423 View Post
                What program(s) was the foliage made in?
                Are the bright spots similar in shape and intensity?

                There's quite a number of potential causes of the bright spots. Try solving one or two objects' bright spots problem, then apply those steps or the solution to other objects. Can you post a few screenshots of the bright areas / spots?
                Here they are. They appear generally on foliage that I loaded through megascans bridge, but I found another on a stone that I loaded from Ue4 asset store. They appear after every light baking. If you move an object spot disappears. Another thing I found is that they may appear on a same place over light building.
                Attached Files

                Comment


                  #9
                  They are similar in size, shape, and intensity. Does it occur in brighter lit areas? A few causes could be volumetric lightmap, the megascans material workup, and skylight cubemap resolution is too low. The volumetric lightmap might be at the wrong values for a darker, forest scene with such dense foliage. Or certain grid samples are not completely represented in the lighting somehow. The material workup might be missing a node, have a wrong setting or lacking one that's enabled/disabled, or the export resolution is off. Is there anything else peculiar about those spots?

                  Comment


                    #10
                    Originally posted by presto423 View Post
                    They are similar in size, shape, and intensity. Does it occur in brighter lit areas? A few causes could be volumetric lightmap, the megascans material workup, and skylight cubemap resolution is too low. The volumetric lightmap might be at the wrong values for a darker, forest scene with such dense foliage. Or certain grid samples are not completely represented in the lighting somehow. The material workup might be missing a node, have a wrong setting or lacking one that's enabled/disabled, or the export resolution is off. Is there anything else peculiar about those spots?
                    I'm sorry that I disappeared. I tried to change everything that you told me and it didn't work. Material is alright cause when I change material for world grid it still has these dots on a grey surface. Also I noticed that I have this kind of blobs on terrain in some places. I changed volumetric lightmap and still nothing. Also about cubemap I increased resolution till 512 and still nothing. I noticed that less of the dots on much brighter areas. Also they different in size, but on the terrain they have size of one square.

                    Comment


                      #11
                      Are any errors displaying from a map check of the level?
                      The volumetric lightmap needs to be tweaked to different values to see if there's a problem with it or if it's influencing the problem. Did you mean there's less dots after increasing cubemap resolution to 512, in the brighter areas? or were the brighter areas having less dots before cubemap of 512?

                      So, the foliage uses world position? but the rest of the scene doesn't?

                      Comment


                        #12
                        Originally posted by presto423 View Post
                        Are any errors displaying from a map check of the level?
                        The volumetric lightmap needs to be tweaked to different values to see if there's a problem with it or if it's influencing the problem. Did you mean there's less dots after increasing cubemap resolution to 512, in the brighter areas? or were the brighter areas having less dots before cubemap of 512?

                        So, the foliage uses world position? but the rest of the scene doesn't?
                        I found an error that could be the cause of my problems. Im not shure so look please.
                        Attached Files

                        Comment


                          #13
                          That's less than enough information to accurately identify the exact issue. Are there LODs other than LOD 0 for the foliage? Have you tried posting in the AnswerHub?

                          Comment


                            #14
                            Originally posted by presto423 View Post
                            That's less than enough information to accurately identify the exact issue. Are there LODs other than LOD 0 for the foliage? Have you tried posting in the AnswerHub?
                            All meshes have 3-4 LODs. I posted but there's no answer.

                            Comment


                              #15
                              How did you create the foliage, precisely? Are you able to list several steps you used to create and distribute the foliage in the landscape?

                              Comment

                              Working...
                              X