Announcement

Collapse
No announcement yet.

Light coming from outside is not exposing interior

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Light coming from outside is not exposing interior

    I'm new to UE4 and I need help here. The problem is basically described in the headline. How do I expose the inside correctly? Project is meant as a minigame not as a pure render.
    What I thought is that the windows (it's just a blockout) would lit the inside correctly. Either by baking or setting the light source to dynamic. But instead when I bake light the result is like this, completely dark.

    Click image for larger version  Name:	1.jpg Views:	4 Size:	297.7 KB ID:	1783169


    The skylight set to moveable here but it doesn't look that much better. To me it feels like the room is just lit with an even softlight. It is not like top is more lit than the bottom, how it should be I guess.


    Click image for larger version  Name:	2.jpg Views:	5 Size:	288.1 KB ID:	1783170

    So what to do to improve that lightning? What is recommended?
    Last edited by Marlo3D; 07-01-2020, 07:21 PM.

    #2
    Where is the post process volume? Is RT enabled? Try baking or using dynamic directional (set to movable, not stationary) after deleting the reflection probe. Then add it in later if the lighting works.

    Comment


      #3
      You might also want to look at adding "Light Propagation volumes" to those window areas.

      https://docs.unrealengine.com/en-US/...mes/index.html

      Comment


        #4
        Add lightmass portals to the windows. You may need to crank up the indirect/skylight bounces also.

        Comment


          #5
          Thanks for all the answer, appreciate the help! A lot to learn here. I will read the documentation and also look at everything up you have suggested me. Thanks! When I have made some progress I will post it.

          Comment

          Working...
          X