Announcement

Collapse
No announcement yet.

Cannot disable refraction on parts of the material

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Cannot disable refraction on parts of the material

    Hello,

    I want to disable refraction on parts of the material, like I can make parts of the material fully translucent (opacity = 0) or mask them out. With refractions this does not seem to work. opacity = 0 or refraction = 0 has no effect, it's always on the whole material refracted.

    Thank you,

    Thilo

    #2
    Can you possibly post a picture / screenshot of what you're trying to achieve with this? That might help track down a solution...

    Comment


      #3
      Try setting refraction to 1, not 0, for the areas you'd like it disabled.

      Comment


        #4
        If you use raytracing for your transparent materials, then the specular input is used for raytraced refraction. So test, if you can disable your refraction via specular input.

        Translucency Index of Refraction (IOR)


        When setting up and using refraction for ray tracing, the Specular material input is used to control the index of refraction, or IOR, in your translucent materials. The ray tracing features of Unreal Engine follows the Disney BRDF model whereby specular and IOR values are coupled and cannot be defined independently.
        https://docs.unrealengine.com/en-US/...ing/index.html

        Comment


          #5
          Thank you all. I had to set refraction to 1, not to 0 like you do it with opacity, to disable it,

          Comment

          Working...
          X