Announcement

Collapse
No announcement yet.

Cine Camera Actor depth of field box blur aliasing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Cine Camera Actor depth of field box blur aliasing

    Hello guys,

    I set up a simple test scene with some Megascans and a cine camera with depth of field. It is pretty impressive, however I have very poor results using the depth of field.

    As you can see in the attached pictures, as I move my camera through the scene, the Focus/OOF point seems to be messed up and it makes big boxy blurry pixels instead of a smooth and progressive 'Out Of Focus' blur.

    Anybody has a solution to avoid it ?

    Thanks, J.
    Attached Files

    #2
    Nobody here knows what could be my issue ?
    If nobody knows, could someone redirect on a page/forum/group where people may be able to answer me ?
    Thanks a lot,
    J.

    Comment


      #3
      Hey Jeremy,

      I haven't seen this yet. I just tried mocking something up quickly and the DOF appears to be working ok for me (see screen shot). Under your camera settings it may be interesting to see what you get when you check the 'Draw Debug Focus Plane' option under focus settings. That should draw a purple plane in the viewport at the focus distance from the camera. What 'Focus Method' are you using? Are you tracking - or using Manual? I did my testing in 4.24.3. Maybe this doc may help?

      https://docs.unrealengine.com/en-US/...ods/index.html

      ​​​​​​​
      If you can send a screen shot of all of your camera settings I can try and match those in my setup to see if I see the problem...

      Comment


        #4
        Hello Brian, thank you very much for your answer !

        I am using 4.25 so the Focus Method is not here anymore (or I didn't find it ?). I am using Manual focus and 3.0 Fstop.
        You can see in the attached screen shot that the blur generated in boxy/pixellized. Maybe I am wrong with how I use DOF, I don't know. There is a lot of ghosting also.

        Thanks,
        Jeremy
        Attached Files

        Comment


          #5
          JeremyShin - I think I'm able to reproduce the blockiness you're referring to. This is what I found matching your camera settings when my Settings -> Engine Scalability Settings were set to 'High':

          Click image for larger version

Name:	badDOF_high.jpg
Views:	69
Size:	472.5 KB
ID:	1775122

          If I set the Engine Scalability Settings to 'Epic' or above I get something much smoother:

          Click image for larger version

Name:	badDOF_Epic.jpg
Views:	52
Size:	452.1 KB
ID:	1775123

          ... perhaps you could try that in your example to see if it helps?

          Comment

          Working...
          X