Announcement

Collapse
No announcement yet.

Niagara in UE 4.25 - particles from a skeletal mesh

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Niagara in UE 4.25 - particles from a skeletal mesh

    Hi. I'm trying to spawn particles from a skeletal mesh like this:

    Click image for larger version

Name:	2020-05-14_14h37_24.png
Views:	198
Size:	204.2 KB
ID:	1760756

    I'm using latest Niagara on Unreal 4.25.
    I've found some tutorials (like this one: https://www.youtube.com/watch?v=RWl3ySXTY2c)

    The problem is that only one particle is spawned from the skeletal mesh, no matters what the rate is.
    It seems a bug or something i don't understand.

    Is it something wrong i do? Or is it a problem concerning the newest version of Niagara / Unreal Engine?

    I really don't know how to menage it
    Can someone help me? Thank you!!!

    Attached Files

    #2
    You need to provide data to the random tri coord node, if not, all particles will spawn on the same location. Instead of using this custom niagara module, after you sampled the skeletal mesh you should use the skeletal mesh position module, that will do exactly what you are trying to achieve

    Comment


      #3
      Thank you. I'm sorry but i'm quite new in unreal... Did you mean the Skeletal Mesh Location module? Like this one?
      It doesn't change anything... Surely it's some data missing here too. I cannot find any tutorials on that.

      Sorry for wasting your time.


      Click image for larger version

Name:	2020-05-15_11h58_44.jpg
Views:	182
Size:	324.0 KB
ID:	1761472

      Comment


        #4
        See https://www.youtube.com/watch?v=cTUnMC6-IeA - it shows you the details to fix. /gv

        Comment


          #5
          Be sure to enable CPU access on your skeletal mesh properties.

          Comment


            #6
            Thank you so much!!!!!

            Comment

            Working...
            X