Announcement

Collapse
No announcement yet.

Reflective/metallic material flickering

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Reflective/metallic material flickering

    Since updating to 4.25, I've been getting flickering on any materials that are reflective. It occurs not only from any light source that's present, but also if there's a bright additive material within the vicinity of it. Below is a video of it.

    Is anyone aware of a setting change I need to make to fix this? Any help would be greatly appreciated.


    #2
    Originally posted by Scyrux View Post
    Since updating to 4.25, I've been getting flickering on any materials that are reflective. It occurs not only from any light source that's present, but also if there's a bright additive material within the vicinity of it. Below is a video of it.

    Is anyone aware of a setting change I need to make to fix this? Any help would be greatly appreciated.

    I also have strange flickering metal, and general lighting weirdness. It's like someone jacked up the skylight and fog actors.

    I also have 'ants' crawling on some metal surfaces.

    Be interested in any answers also...
    Check out Zof ( puzzle game ) on Steam:

    https://store.steampowered.com/app/1414480/Zof/

    Comment


      #3
      I have same issue in 4.25 all reflective materials are flickering even the UE4 starter content materials. How to fix it?
      It occurs both in editor and in play mode.
      Last edited by wortek; 05-13-2020, 10:44 AM.

      Comment


        #4
        OK turns out for me it was this setting in DefaultEngine.ini in Config folder of my project:
        [/Script/Engine.RendererSettings]
        r.DefaultFeature.AntiAliasing=1

        Removing this parameter fixed the flickering issue.

        Found out that when creating a new empty project there is no such settings in the DefaultEngine.ini and everything worked.

        So for anyone who's having this issue just play with DefaultEngine.ini config file try removing some lines and see how project will react.

        Comment


          #5
          Originally posted by wortek View Post
          r.DefaultFeature.AntiAliasing=1
          Thanks, Wortek.

          Removing that line from DefaultEngine.ini seems to have fixed it for me.

          Comment


            #6
            Hi, I also had the same problem. https://forums.unrealengine.com/deve...asing-problems But not yet tried this fix.

            Comment


              #7
              Originally posted by tridasha View Post
              Hi, I also had the same problem. https://forums.unrealengine.com/deve...asing-problems But not yet tried this fix.
              It's not really a fix. It might stop the metal flickering, but your game will look jagged as hell.
              Check out Zof ( puzzle game ) on Steam:

              https://store.steampowered.com/app/1414480/Zof/

              Comment


                #8
                Originally posted by ClockworkOcean View Post

                It's not really a fix. It might stop the metal flickering, but your game will look jagged as hell.
                That line has been removed from new versions of the DefaultEngine.ini. The anti aliasing is not affected by removing it from your older version.

                Comment


                  #9
                  I had the same issue. Changing the 'Anti-Aliasing method' in Project Settings from 'FXAA' to 'TemporalAA' fixed it for me. Using UE 4.25. Not the best solution, but it works untill Epic fixes the bug.
                  'Crystals Of Theia' - an adventure/action/puzzle game a la Tomb Raider/Uncharted/Deadfall Adventures

                  'Crystals Of Theia' on IndieDB - an adventure/action/puzzle game a la Tomb Raider/Uncharted/Deadfall Adventures

                  Comment


                    #10
                    Hello,

                    ****** HERE'S FLICKERING FIX *********************

                    Official 4.25 and 4.26 having some glitches in calculations, namely TemporalAAHistory structure was not filled out correctly

                    Here's the only solution that will surely fix for both 4.25 and 4.26 versions (building from the source and fixing engine glitch), since 4.25 will not have any more updates and 4.26 also has the same issue:

                    1. get Unreal 4.25 source, following link is a step by step instructions on how to get the source (no need for the building until you change buggy scripts, just when you get 4.25 source unzipped from git, run Setup.bat, after that run GenerateProjectFiles.bat ): https://www.youtube.com/watch?v=dZck...l=MichaelAllar

                    2. change this 2 scripts as explained in the below link, and finally, build the source
                    https://github.com/EpicGames/UnrealE...48f5a38dfb53ea

                    3. compile your project from source (in the following link, instructions are around 8.50 min): https://www.youtube.com/watch?v=dZck...l=MichaelAllar

                    ************************************************************
                    Enjoy again your UE4.25/26

                    Cheers,
                    Mike

                    Comment

                    Working...
                    X