Announcement

Collapse
No announcement yet.

Landscape Blending Materials

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Landscape Blending Materials

    Hi everyone,

    I am new to using Unreal 4 so I apologize if I am asking stupid questions.

    I have blended two materials so I can paint my 15 x 15 landscape but every time I go to paint the second mud layer on top of the grass, the edges don't blend properly and I keep getting shiny spots. Does anyone know what the issue is and how to rectify it?

    I've put two screenshots below which shows my landscapes the material nodes I used to set up the master material

    Click image for larger version

Name:	Screenshot-6.jpg
Views:	87
Size:	504.8 KB
ID:	1751745 ​​​​​​​


    Click image for larger version

Name:	Screenshot-7.jpg
Views:	130
Size:	432.8 KB
ID:	1751744

    #2
    Hi,

    (1) Did you check that your diffuse textures (the two textures above the normal maps) have an alpha channel?

    (2) Normal maps don't have an alpha channel, so using the alpha channel there won't give you meaningful results (generally you would use the alpha from the two diffuse textures above)

    (3) Where you blend the roughness you would also need an height input, else it will use a fixed value and since you use a height input for base color and normal map, it might look odd (again alpha from the diffuse textures)

    Comment


      #3
      Hi,

      (1) I'm fairly certain that they have an alpha channel but I’ll double check this

      (3) Would I need the roughness textures of the material I am using to do this?

      Comment


        #4
        (3) Would I need the roughness textures of the material I am using to do this?
        Hmmm, not quite sure I understand what you mean. The height input is independent from the layer input. It only specifies how to blend between the layers. So for one layer you should generally use the same height input in every landscape layer blend node, unless you intentionally want to blend them differently.

        Comment


          #5
          Originally posted by O_Bryant View Post
          Hi,

          (1) I'm fairly certain that they have an alpha channel but I’ll double check this

          (3) Would I need the roughness textures of the material I am using to do this?
          Hi,
          You don't need the textures if you're fine only using values, other than that as Chrudimer said : your blending method needs to be consistent between all of your texture inputs
          Also, normal maps don't have alpha channel and adding one would prevent then from using the normalmap compression format from UE. Which you really want to keep unless you know what you're dealing with.
          You can add your heightmaps inside the alpha channel of each of your diffuse texture if it's not the case already, or have them as separate textures but it would cost you 2 extra textures


          Based on your screenshot, your issue might comes from the normal and roughness. You're not blending the roughness the same way you blend the diffuse and the normal map are most certainly not using any heightmap info to blend

          Hope that helps !

          Comment


            #6
            Originally posted by Azraen View Post
            your blending method needs to be consistent between all of your texture inputs
            Not true at all. check the docs:
            When using certain combinations of layer blend modes you could end up with black spots all over your Landscape where different layers meet. This problem is especially prevalent when using the LB_HeightBlend mode for multiple Landscape layers. LB_HeightBlend works by modulating the blend factor, or weight, for the layer using the specified height value. When you have multiple layers painted on an area and they all are set to LB_HeightBlend, it is possible that all the layers painted in a particular area will simultaneously have a 0 height value, so the desired blend factor for each layer becomes 0.
            https://docs.unrealengine.com/en-US/...als/index.html

            I would disable the roughness blend altogether. but if you want to use it definitely either feed in the same height-maps or switch to alpha blend.

            Also feed the same alpha from the initial textures into the Normal map - the height blend is supposed to be the same.

            You can change to using only 1 node by creating attributes with Make Material Attributes, which may be a little easier to "picture".
            You create the "layer", then feed it into the blend - using the texture's alpha.

            It should also theoretically be "easier" on performance.
            Last edited by MostHost LA; 04-29-2020, 05:56 PM.

            Comment

            Working...
            X