Announcement

Collapse
No announcement yet.

Model Turning Translucent when exported into Unreal from Blender

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Model Turning Translucent when exported into Unreal from Blender

    Hi All,

    I've just started out and have made my first basic model in blender that I'm now exporting into unreal, It's an odd shaped door frame with 2 handles attached, which are parented and intersecting the frame slightly.

    It loads into Unreal engine fine but has turned slightly translucent, but only to the other faces of the frame, the frame itself is just a basic white colour and looks fine in Blender, I read up about it and tried deleting all Internal Faces, and have adjusted all the normals, so all faces are blue and all lines are pointing outwards but neither of these have helped.

    If anyone has any suggestions it'd be much appreciated.

    #2
    I smart Unwrapped in Blender, went through and did it manually after your post.
    Downloaded the texel viewer and standardised all texels as best I could (I didn't know anything about this originally)
    Mesh face orientation is correct, All showing blue in blender
    I went through and painted both sides of the mesh in blender but it's not changed anything

    Below is how it appears in Unreal, it's showing the shading through the material but isn't actually translucent
    Click image for larger version

Name:	Unreal-Screenshot.jpg
Views:	71
Size:	76.1 KB
ID:	1751547

    Below is how it looks in Blender
    Click image for larger version

Name:	Blender-Screenshot.jpg
Views:	43
Size:	89.1 KB
ID:	1751548

    I may retry with a more basic model, I wonder if it's just a mistake I've made whilst modelling

    Comment


      #3
      Your normals are inverted. Select all faces in blender, go to the face menu and select Flip Normals. And just in case it still looks wrong, make sure your import settings in Unreal are set to “Import Normals and Tangents”.

      Comment


        #4
        The reason it looks right in blender is because blender does not cull backfaces by default, you have to enable that in the 3D viewport settings.

        Comment

        Working...
        X