Announcement

Collapse
No announcement yet.

Problem with Static Lighting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problem with Static Lighting

    Whenever i add static lights in my interior level and build it, the shadows come out really bad (see the screenshots). I tried playing around with lightmap resolutions and some of the settings in the details section but nothing helped except to use stationary or movable lights. Please help...

    #2
    Originally posted by hillofgold View Post
    Whenever i add static lights in my interior level and build it, the shadows come out really bad (see the screenshots). I tried playing around with lightmap resolutions and some of the settings in the details section but nothing helped except to use stationary or movable lights. Please help...
    Using stationary is fine, they're static, but adjustable.

    I'm not sure what's going on with your floor mesh, is that separate meshes?

    But the desks, that's the lightmap resolution of the desk begin too low...

    Comment


      #3
      I would use stationary but there can only be 4 used at a time i think?

      Yes, the floor is made of modular pieces. Maybe it's the UVs? I'm not sure because i bought the assets from the moarketplace.

      As for the lightmap resolution, i tried up to 1024 but it didn't solve the problem.
      Last edited by hillofgold; 04-26-2020, 09:55 AM.

      Comment


        #4
        Originally posted by hillofgold View Post
        I would use stationary but there can only be 4 used at a time i think?

        Yes, the floor is made of modular pieces. Maybe it's the UVs? I'm not sure because i bought the assets from the moarketplace.

        As for the lightmap resolution, i tried up to 1024 but it didn't solve the problem.
        Do the assets even have lightmap UVs? Did you check in the mesh editor?

        Comment


          #5
          It does have uv channels 0, 1 and 2. I think the source / destination lightmap index or lightmap coordinate index affect this, but what values should i set them?

          Comment


            #6
            When you imported your mesh into UE4 you had the option to automatically generate a lightmap UV channel enabled (it's checked by default) and what that does is it copies the existing UV's to a new channel and runs an algorithm to flatten them and then assigns them as the new Lightmap Coordinate Index
            That's why you have 3 UV channels, it's set the index to 2 (since the first channel is 0)

            Looking at the first screenshots, the black shadow on there indicates that the lightmap UV's are overlapping

            Comment


              #7
              Thank you for your input!

              The Generate Lightmap UV option is not checked and i didn't change it, i guess the artist created the 3rd uv channel manually or changed the setting.

              As for UV overlapping, so far i have not received an error message regarding that when building lighting.

              Comment


                #8
                Hi!

                The first screenshot looks like bad/missing reflection capture placement to me...
                64 res lightmap for such a complex mesh is way too low...

                Comment


                  #9
                  Thanks for informing me about the reflection capture, i will add it in.

                  I'll use stationary instead of baked since it looks way better and bump the lightmap res, but i hope i won't run into performance issues.

                  Comment

                  Working...
                  X