Announcement

Collapse
No announcement yet.

Bad shadow quality !

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Bad shadow quality !

    Hello everyone !

    I have some trouble with shadows, the compute quality of the pictures i'm gonna share are in production mode. For your information i have some overlapping & wrapping UV on some props, but i don't know if it can affect the global shadows quality of the scene for every props ?
    Minimum lightmap resolution are set to 64.

    This is the shadows if i set the DirectionalLight to "Stationary" and compute it in production (even in preview for sure it's the same) :
    Click image for larger version

Name:	bad.png
Views:	180
Size:	334.8 KB
ID:	1746700

    And this is the same one with movable :
    Click image for larger version

Name:	bad.png
Views:	122
Size:	505.0 KB
ID:	1746701

    Can someone please help ?


    Thanks a lot

    #2
    Okay i fixed the problem by modifying "Dynamix Shadow Distance" --> Num Dynamic Shadow Casc" & "Distribution Exponent".

    Click image for larger version

Name:	Sans-titre.png
Views:	141
Size:	12.7 KB
ID:	1746718

    Comment


      #3
      render preview problem in 4.24 any idea we check 4.24 and 4.25 but both same problem movie render preview not show video but output video is fine any idea preview window size change????

      Comment


        #4
        Hello samrat333, i'm sorry but i didn't understand what you said exactly. Can you please explain in details what kind of problem do you have ? Give more details and maybe also some screens ?
        Last edited by Krystoh; 04-23-2020, 02:02 PM.

        Comment


          #5
          Originally posted by Krystoh View Post
          Okay i fixed the problem by modifying "Dynamix Shadow Distance" --> Num Dynamic Shadow Casc" & "Distribution Exponent".

          Click image for larger version

Name:	Sans-titre.png
Views:	141
Size:	12.7 KB
ID:	1746718

          Your wasting an a ton shadow resolution and are clearly brand new to shadows. Set distribution exponent to 3 or 2 (I choose 2, but 3 is better for close details, 4 and 1 should never be used), Set distance to 2000 to 7500 (You can go further but there's no point with stationary), And set cascades from 1 to 3, even 3 is completely overkill for these distances but if you want to, you can. Set your lightmap resolution higher on troublesome objects after that (make sure its a power of 2) for better far shadows.
          Originally posted by samrat333 View Post
          render preview problem in 4.24 any idea we check 4.24 and 4.25 but both same problem movie render preview not show video but output video is fine any idea preview window size change????
          Post your own thread, as your question is far more likely to be answered that way.

          Comment


            #6
            Hello Bits360 thanks a lot for your message !
            I've set this first to the max just to check if the problem was from here or not and then i've modified it, because yes i am pretty new with shadows, i was never been so far in details before now.

            This is my actual settings :
            Click image for larger version

Name:	Capture.JPG
Views:	94
Size:	24.9 KB
ID:	1749836

            It's near what you said ! I'm going to try cascades at 2 and see the differences thanks a lot. For the lightmap resolution i have some trouble yeah, i set some objects to 256 but still have overlapps issues but i'm going to fix it by modifying UV and UV chanels.

            --> But my problem is, and i don't know why, there is some mesh who i can't chose the UV chanel number 1 (even if there is one)..but it is another problem !

            However, sorry i didn't understand well when you said : "Set distance to 2000 to 7500", i think you mean i must set shadow distance statlight to 2000, right ? Just to be sure, i'm going to test it anyway now.

            Thanks a lot for your time & for your help !

            Comment


              #7
              Originally posted by Krystoh View Post
              Hello Bits360 thanks a lot for your message !
              I've set this first to the max just to check if the problem was from here or not and then i've modified it, because yes i am pretty new with shadows, i was never been so far in details before now.

              This is my actual settings :
              Click image for larger version

Name:	Capture.JPG
Views:	94
Size:	24.9 KB
ID:	1749836

              It's near what you said ! I'm going to try cascades at 2 and see the differences thanks a lot. For the lightmap resolution i have some trouble yeah, i set some objects to 256 but still have overlapps issues but i'm going to fix it by modifying UV and UV chanels.

              --> But my problem is, and i don't know why, there is some mesh who i can't chose the UV chanel number 1 (even if there is one)..but it is another problem !

              However, sorry i didn't understand well when you said : "Set distance to 2000 to 7500", i think you mean i must set shadow distance statlight to 2000, right ? Just to be sure, i'm going to test it anyway now.

              Thanks a lot for your time & for your help !
              "It's near what you said ! I'm going to try cascades at 2 and see the differences thanks a lot. For the lightmap resolution i have some trouble yeah, i set some objects to 256 but still have overlapps issues but i'm going to fix it by modifying UV and UV chanels." Overlaps are an issue with the model itself, 256 is really low, and only used on small objects, Ex: A lamp

              "However, sorry i didn't understand well when you said : "Set distance to 2000 to 7500", i think you mean i must set shadow distance statlight to 2000, right ? Just to be sure, i'm going to test it anyway now." 2000 to 7500 is a range, choose whatever number between it looks good, go higher if you want, im not stopping you, but, going lower is a bit wasteful as it will barely cover any of your screen.

              You can get a little bit more resolution by changing min lightmap resolution to the lowest lightmap resolution used in your model, shown in the attachments, you can set the standard lightmap resolution in the model's general settings.

              Comment


                #8
                Okay perfect, thanks for all this explanation i understand now !
                It's really helpful to me

                Comment

                Working...
                X