Announcement

Collapse
No announcement yet.

SceneCaptureComponent2D captures motion blur even if disabled

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    SceneCaptureComponent2D captures motion blur even if disabled

    I've run into a curious bug that I could use some help solving. I recently implemented portals (similarly to Fabrice Piquet's method: https://www.froyok.fr/blog/2019-03-c...nreal-engine-4) using a SceneCaptureComponent2D and screen aligned UVs. The effect looks great, with the exception of motion blur. The motion blur showed by the capture component becomes stronger the closer you get to it, resulting in a very jarring effect when looking at the portals from close up:
    Click image for larger version  Name:	UE4-portal-blur-4.gif Views:	0 Size:	582.6 KB ID:	1743286
    Disabling the motion blur either in the portal's screen capture component blueprint or in code via bOverride_MotionBlurAmount / MotionBlurAmount has no effect. The only way I was able to remove the overwhelming blur in the portals was by removing motion blur from the scene entirely, which is not an ideal solution. A similar thread was raised a number of years ago (see: https://forums.unrealengine.com/deve...2d-motion-blur) but with no apparent resolution. Can anyone help with this issue?

    #2
    Hey, I know it's been a while since this was posted, but I was running into a similar problem myself. As it turns out, it was the anti-aliasing that was causing the problem for me. As long as you change it (from the project settings) from TemporalAA to any other method, it worked for me. This problem caused me a bunch of heartache, but I hope this solution reaches well. Cheers!

    Comment

    Working...
    X