Announcement

Collapse
No announcement yet.

Weird Shadows

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Weird Shadows

    I'm having some weird shadows occur after building the lighting, does anyone know what could be causing this?
    Click image for larger version

Name:	weirdshadows.PNG
Views:	97
Size:	261.1 KB
ID:	1743083




    The floor isnt just a flat texture, it does have some sort of mesh to it

    Click image for larger version

Name:	2.PNG
Views:	75
Size:	309.9 KB
ID:	1743084


    #2
    You need better UV mapping for your lightmap. Also you should consider whether you should actually have the wood planks modeled like that, you can achieve those cracks with normal maps and reduce the polygon count.

    Comment


      #3
      Originally posted by darthviper107 View Post
      You need better UV mapping for your lightmap. Also you should consider whether you should actually have the wood planks modeled like that, you can achieve those cracks with normal maps and reduce the polygon count.
      The polygon counts is very minimal, less than 1k, but yeah i could try that, maybe it would solve the lighting issue, and how do i get 'better UV mapping'?

      Edit: I tried using a flat plane with normal maps but as my character is very close to the ground it doesn't look good enough for my use
      Last edited by ToxicFuglet; 04-08-2020, 04:06 PM.

      Comment


        #4
        Originally posted by ToxicFuglet View Post

        The polygon counts is very minimal, less than 1k, but yeah i could try that, maybe it would solve the lighting issue, and how do i get 'better UV mapping'?

        Edit: I tried using a flat plane with normal maps but as my character is very close to the ground it doesn't look good enough for my use
        A: Better uv mapping as in dont use a million seams, it butchers the lightmap and the texture itself
        B: Parallax occlusion mapping is where its at.

        Comment


          #5
          Try looking deeper into the issue before resorting to flat-only geometry to reduce polygons. It doesn't appear to be a geometry / mesh form problem. The weird shadows are irregular and not everywhere. They're not looking like they're in tandem somehow with the floor's mesh pattern. Increase lightmap resolution by 2-3 steps, if possible. Create a distance field mesh per floor tile, or perhaps group those meshes into one big floor mesh and generate the distance field mesh for it. Make it a two-sided distance field (this is all in the mesh editor for it / those tiles), and increase the distance field resolution if it's still not looking right.

          Another possibility is to use ambient occlusion in the post process volume and tweak settings to cause those weird shadows / artifacts to disappear.

          Comment

          Working...
          X