Announcement

Collapse
No announcement yet.

Basic RayTracing spheres - not reflecting each other

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Basic RayTracing spheres - not reflecting each other

    Trying to understand reflections in ray tracing setup. I have simple scene with ray tracing enabled, a white emission sphere surrounding 2 metallic spheres inside. The two metallic spheres do not reflect each other, they are black. I have Max Bounces set to the highest they can go (50). I've included my ProstProcessVolume in my screen capture.

    What am I missing?

    Windows 10, RTX 2080TI, Nvidia Driver 431.86

    #2
    Make sure under your post process you go under the 'Reflections' drop down and change it from Screen Space to Ray Tracing. This won't show up if you just type 'ray' in the search bar. Also make sure you have it set to 'Infinite' enabled.

    Comment


      #3
      thanks IamBramer, unfortunately both of those are already enabled as well.

      Comment


        #4
        I did some quick testing in a scene and it would appear that 2 pure black sphere's will not reflect values into each other.

        I'm fairly certain that this has to due with the PBR values that are setup for how the engine handles these materials. If you actually look at real life metal's, I'm also fairly certain they don't have such values existing in their properties. (reference this article here: https://digitalcolony3d.com/2019/07/25/albedo-chart/ ) Metals albedo values are between 0.5 and 0.98. Lower values are for matte, higher are for polished metal.

        You'll have to fake this effect artistically if you want to have a 'black metal'. (Keep in mind the 'darkness' on most metals is from lack of light not from being black.) I found that you can start to get reflective bounces starting around .1 in the base color depending how much light you have in the scene. Most likely you're better off setting up a non metallic material with little or no roughness and working from there.

        Comment


          #5
          Thanks for the information IamBramer!

          Yes, I guess it does need to be artificially created for artistic control. I'll have to keep working with it to get what I'm looking for.

          Cheers.

          Comment


            #6
            What effect is the ultimate goal? I know it's a 2080Ti, but 50 bounces for reflections sounds too high. It's not always the graphics card that's in question, it's also the scene rendering capacity and how the materials are designed. It's even noted in the RT doc about multi-bounce, RT reflections.

            Comment


              #7
              Originally posted by LFedit View Post
              Trying to understand reflections in ray tracing setup. I have simple scene with ray tracing enabled, a white emission sphere surrounding 2 metallic spheres inside. The two metallic spheres do not reflect each other, they are black. I have Max Bounces set to the highest they can go (50). I've included my ProstProcessVolume in my screen capture.

              What am I missing?

              Windows 10, RTX 2080TI, Nvidia Driver 431.86
              Well, they DO reflect each other, and that reflection are those small completely black spots near the contact point. The problem in your scenario is the color of your spheres, they are already black before the reflections starts, which reduces the amount of light with every reflection even more. But if you start from black, then every other reflection would be lower, but it cannot go lower than black, unless negative colors are introduced ^.^
              With reflections you have to keep in mind, that every reflected image contains only a fraction of the originally incoming light, never 100% (max for perfect mirrors in reality is 99,9x%), so you will always end up with a loss of light intensity with every reflection. But black is zero light/color, and you cannot go below zero in light intensity.

              So try a light grey for your sphere color and test it again, then you will see several reflections of them, until the reflected amount of light becomes to low and turns black again.
              Last edited by Suthriel; 04-15-2020, 03:25 PM.

              Comment


                #8
                Do a dual-normal, clear-coat surface on top of the black base color.

                Comment


                  #9
                  presto423 thanks for the suggestion. Is this approach using a lerp and blending two textures? I'm unfamiliar with a dual-normal, and a clear-coat top surface.

                  Thanks,

                  Comment


                    #10
                    Dual-normal is enabled in the project settings and the Clear Coat shading model is set in the material editor for it. Here's a link to the basic how-to about it:

                    https://docs.unrealengine.com/en-US/...mal/index.html

                    It involves at least 1 lerp, and the ClearCoatBottomNormal expression node. The rest is basically roughness, 2 normal maps, math, and several other basic nodes...not too complex.

                    So, one black, smooth surface for the bottom layer (with bottom normal expression node), and a second smooth surface for the top layer that is probably the more reflective surface.

                    Comment

                    Working...
                    X