Announcement

Collapse
No announcement yet.

Everything that is not directly facing the sun turns black when using dynamic lighting.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    It doesn't seem like scattering values would do it, but it was probably worth testing. Try deleting it, and then undo to bring it back. What are the Exponential Height Fog's settings (including its location values)? Two screenshots would suffice to get all the settings.

    Is there a post process volume (PPV)? If it's set to Unbound, then certain settings can affect things even if they're not enabled (checked), such as the tonemapper.

    Leave a comment:


  • replied
    Originally posted by presto423 View Post
    If there's AtmosphericFog in the scene, go to its Details panel, down to Ground (expand it), and put a check in "Disable Ground Scattering". Try that and see if it returns the ceiling to normal.
    There is no atmospheric fog, there is only exponential height one. i tried messing with the scattering values there, but nothing helps.

    Leave a comment:


  • replied
    If there's AtmosphericFog in the scene, go to its Details panel, down to Ground (expand it), and put a check in "Disable Ground Scattering". Try that and see if it returns the ceiling to normal.
    Last edited by presto423; 04-06-2020, 01:07 PM. Reason: to describe the setting correctly

    Leave a comment:


  • replied
    Originally posted by SLIVER_Pirolye View Post
    Well it works I guess....

    Now the ceiling is a washed out grey.
    The skybox itself's lower hemisphere is the same color, just noticed, are you using a custom sky or something? Dynamic skylight gets color from skybox.

    Leave a comment:


  • replied
    Is the ceiling supposed to be the same grey as the rest of the indoor area?

    Leave a comment:


  • replied
    Well it works I guess....
    Originally posted by Bits360 View Post
    Add a skylight. Also, disable Lower Hemisphere is Solid Color on said skylight.
    Now the ceiling is a washed out grey.
    Attached Files

    Leave a comment:


  • replied
    Originally posted by Bits360 View Post
    Add a skylight. Also, disable Lower Hemisphere is Solid Color on said skylight.
    I already have one, as it is required for dynamic lighting. I'll try the other suggestion.

    Leave a comment:


  • replied
    Add a skylight. Also, disable Lower Hemisphere is Solid Color on said skylight.

    Leave a comment:


  • Everything that is not directly facing the sun turns black when using dynamic lighting.

    So yeah. Any suggestions are greatly appreciated.
Working...
X