Announcement

Collapse
No announcement yet.

Wall Turn Black When Building Lightning

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Wall Turn Black When Building Lightning

    Hello! I made a small room in my game with the same meshes for walls, floor and roof. When I build lightning this happens: https://imgur.com/a/eZrxWzS Any help is appreciated! Thanks in advance!

    #2
    I've had that happen before in a similarly simple room made of all the same mesh types and material. I tried changing to stationary lighting, and then dynamic, and it got worse when changing to stationary...and not as bad in changing to dynamic. Another thing that reduced the seams, different shades of lighting among meshes, and darkening was setting all meshes to utilize Channels 0 and 1 for lighting. So, I selected all the meshes in the World Outliner, scrolled down to the Lighting Channels in details panel, and enabled the next channel (Channel 1). I also enabled that channel in all the lights that I could. Really, it requires starting from one mesh, opening Static Mesh Editor for that mesh, and generating new lightmap UVs for it after enabling Channel 1 for it and ensuring that the new lightmap UVs are sent to Channel 1 (Destination Lightmap Channel in the mesh's settings inside Static Mesh Editor). Then in copying it and making new meshes, or mesh instances, those lightmap UVs are there. I think there should be a generate lightmap UVs button in the main editor that generates the UVs right there without having to go into the Static Mesh Editor. It'd save a ton of time, effort, and issues.

    Comment


      #3
      Originally posted by presto423 View Post
      I've had that happen before in a similarly simple room made of all the same mesh types and material. I tried changing to stationary lighting, and then dynamic, and it got worse when changing to stationary...and not as bad in changing to dynamic. Another thing that reduced the seams, different shades of lighting among meshes, and darkening was setting all meshes to utilize Channels 0 and 1 for lighting. So, I selected all the meshes in the World Outliner, scrolled down to the Lighting Channels in details panel, and enabled the next channel (Channel 1). I also enabled that channel in all the lights that I could. Really, it requires starting from one mesh, opening Static Mesh Editor for that mesh, and generating new lightmap UVs for it after enabling Channel 1 for it and ensuring that the new lightmap UVs are sent to Channel 1 (Destination Lightmap Channel in the mesh's settings inside Static Mesh Editor). Then in copying it and making new meshes, or mesh instances, those lightmap UVs are there. I think there should be a generate lightmap UVs button in the main editor that generates the UVs right there without having to go into the Static Mesh Editor. It'd save a ton of time, effort, and issues.
      I tried this method but it looks the same.I tried settng the light map resolutin to something high.that fixed abit but not enough to be reliable.

      Comment


        #4
        Remade the room in blender, not unreal.it's better but still looks very bad. https://imgur.com/a/azv9YFw No idea how to fix this...

        Comment


          #5
          What lighting methods are in the scene? It appears there's some shadowing leaks or something, and it resulted in different brightness / darkness per wall mesh. It switched from occuring mostly on the ceiling to mostly on the walls. That's really odd, and I suspect it may have something to do with one or two of the lighting methods' settings in the scene.

          Comment


            #6
            Point Light inside and directional light outside.I set the lightmap to a higher value and it kinda fixed the problem.https://imgur.com/a/MXUxHcv
            But now my problem is that the point lights can be seen through the doors like this:https://imgur.com/a/N6kXezT
            I tried some settings on the door but nothing worked..

            Comment


              #7
              Point lights have an attenuation radius, and a soft radius. I'm not sure, but if either one extends past a 3d object (a wall or a doorway), then it's going to shadow the other side too, and probably incorrectly. I see the light 'leak' in the first photo, which is definitely the point light's 'influence'.

              Comment


                #8
                what type of light should I use instead?

                Comment


                  #9
                  Don't make your walls that way, a wall should be one mesh max, or you can even model all of the walls in a room to one mesh. When you split it up unnecessarily then it can cause lighting issues like that along with being worse for performance.

                  Comment


                    #10
                    In the new pictures the room is 1 mesh, the door is a separate mesh.

                    Comment


                      #11
                      That's just it. I don't know. It shouldn't cause an issue if the point light is merely a bit past the walls, ceiling, etc. And it shouldn't be visible through the closed door. That's a different problem, not due to attenuation radius or source radius of the light. I think it's a bug. The light leak is caused by something else. The room's mesh was made in Blender, right? On exporting, were the axes settings changed from Blender's to UE's (Y to Z up, and -Z or -X to X)?

                      Comment


                        #12
                        Yes, everything is made in blender and the axes are right.I found a way to fix the light going throught by turning cast shadow to on, but if I do that when the door opens it had a weird effect on it.

                        Comment


                          #13
                          I discovered something that I think is connected to the problem. Is the Source Radius set on the light? If the source radius is set to lower than the Attenuation radius, then the light fades in influence (brightness and effect on surroundings) from Source Radius to Attenuation Radius. So, if SR is set to 1000 and AR is set to 1500, then from 1000 to 1500 (1500-1000 = 500 UE units) it's fading from its full influence to no light. Try setting it so the influence is almost completely faded at the top and bottom edges of the room. Then the light won't be enough to go through the other side of the wall's mesh.

                          If it doesn't work, then it's obvious it's another cause. It could be lightmap mixing with the other lighting method of the scene (directional), or light mixing (without lightmaps). For when the door's open and has a weird effect, perhaps changing the Shadow Bias is a partial or complete solution.

                          Comment


                            #14
                            you are a hero! I changed the settings as you said and it looks perfect! https://imgur.com/a/CrnHHoD Thanks alot for the help and your time!!

                            Comment


                              #15
                              Awesome! I tested a point light in my basic 3P shooter scene, and it wasn't generating light leaks. Was the light being visible through the door fixed as well?

                              Comment

                              Working...
                              X